summaryrefslogtreecommitdiff
path: root/package/beecrypt
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-03-26 16:01:32 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-03-26 16:01:32 +0100
commit205839d085508b83d9437f2fbe002ef076aa0cdb (patch)
treefba895d01b3d8bbbc87c626d3017ce2b3e95767d /package/beecrypt
parent1015a2e1f56566519d983acca34130ad4ee2f523 (diff)
beecrypt: only build C++ support if dependencies are available
Instead of automatically pulling in the (big) icu library if the toolchain dependencies are available. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/beecrypt')
-rw-r--r--package/beecrypt/Config.in7
-rw-r--r--package/beecrypt/beecrypt.mk2
2 files changed, 1 insertions, 8 deletions
diff --git a/package/beecrypt/Config.in b/package/beecrypt/Config.in
index 8d63e5e6d..84754e534 100644
--- a/package/beecrypt/Config.in
+++ b/package/beecrypt/Config.in
@@ -1,8 +1,6 @@
config BR2_PACKAGE_BEECRYPT
bool "beecrypt"
depends on BR2_TOOLCHAIN_HAS_THREADS
- select BR2_PACKAGE_ICU if BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR && \
- !BR2_arc && !BR2_BINFMT_FLAT
help
Beecrypt is a general-purpose cryptography library.
@@ -10,8 +8,3 @@ config BR2_PACKAGE_BEECRYPT
comment "beecrypt needs a toolchain w/ threads"
depends on !BR2_TOOLCHAIN_HAS_THREADS
-
-comment "beecrypt C++ support needs a toolchain w/ wchar"
- depends on !BR2_arc
- depends on !BR2_BINFMT_FLAT
- depends on BR2_INSTALL_LIBSTDCPP && !BR2_USE_WCHAR && BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index 223b44fb3..c77782c81 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -22,7 +22,7 @@ BEECRYPT_CONF_OPT = \
--without-python \
--disable-openmp
-ifeq ($(BR2_PACKAGE_ICU),y)
+ifeq ($(BR2_INSTALL_LIBSTDCPP)$(BR2_USE_WCHAR)$(BR2_PACKAGE_ICU),yyy)
# C++ support needs icu
BEECRYPT_DEPENDENCIES += icu
else