summaryrefslogtreecommitdiff
path: root/package/beecrypt
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-08-15 14:46:42 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-17 22:45:25 +0200
commita1c16fb29926d2cc9b65229befc1a08ac11b14e8 (patch)
tree6fa1999a7df724b2401d16eae9c32ae2dcb899c7 /package/beecrypt
parent4c71130b613734e06641359cf005c0cfe9cdfb15 (diff)
package/beecrypt: fix C++ support
C++ support unconditionally needs shared libraries; it uses dlopen/dlsym. Also, fix the conditions under which the comment is shown. Finally, explicitly require C++ support when configuring. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/beecrypt')
-rw-r--r--package/beecrypt/Config.in6
-rw-r--r--package/beecrypt/beecrypt.mk1
2 files changed, 5 insertions, 2 deletions
diff --git a/package/beecrypt/Config.in b/package/beecrypt/Config.in
index b9685ef3b..fc93a7760 100644
--- a/package/beecrypt/Config.in
+++ b/package/beecrypt/Config.in
@@ -17,13 +17,15 @@ config BR2_PACKAGE_BEECRYPT_CPP
depends on BR2_USE_WCHAR # icu
depends on !BR2_BINFMT_FLAT # icu
depends on BR2_ARCH_HAS_ATOMICS # icu
+ depends on !BR2_STATIC_LIBS
select BR2_PACKAGE_ICU
help
Enable C++ support. This pulls in the (large) icu package.
-comment "C++ support needs a toolchain w/ wchar"
+comment "C++ support needs a toolchain w/ C++, wchar, dynamic libraries"
depends on !BR2_BINFMT_FLAT
depends on BR2_ARCH_HAS_ATOMICS
- depends on BR2_INSTALL_LIBSTDCPP && !BR2_USE_WCHAR
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR \
+ || BR2_STATIC_LIBS
endif # BR2_PACKAGE_BEECRYPT
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index cd0b4ac96..e66cec10d 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -19,6 +19,7 @@ BEECRYPT_CONF_OPTS = \
ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
BEECRYPT_DEPENDENCIES += icu
+BEECRYPT_CONF_OPTS += --with-cplusplus
else
BEECRYPT_CONF_OPTS += --without-cplusplus