summaryrefslogtreecommitdiff
path: root/package/beecrypt
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2016-06-18 13:26:11 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-06-18 23:38:29 +0200
commita5e57a8b6cd496dff3a4b25efcd443cc5eff0b9a (patch)
treee3098f3fb0fa07ec55487936a3b5bb4bc5a6598e /package/beecrypt
parent2f885bded731bb51c73bee1f84776c0687de6f12 (diff)
beecrypt: fix compile for coldfire
Package uses m68k optimization, which doesn't work with coldfire. These optimizations are disabled with --enable-debug. Fixes following autobuild failure: http://autobuild.buildroot.net/results/bbe57a096de207b78e069591e21ac5a79eab069e/ http://autobuild.buildroot.net/results/ab702e6db382b1975d0cd61feaba9812830e81e8/ Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/beecrypt')
-rw-r--r--package/beecrypt/beecrypt.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
index e66cec10d..4fcdf439a 100644
--- a/package/beecrypt/beecrypt.mk
+++ b/package/beecrypt/beecrypt.mk
@@ -17,6 +17,11 @@ BEECRYPT_CONF_OPTS = \
--without-python \
--disable-openmp
+# disable optimized m68k assembly as it doesn't compile for coldfire
+ifeq ($(BR2_m68k_cf),y)
+BEECRYPT_CONF_OPTS += --enable-debug
+endif
+
ifeq ($(BR2_PACKAGE_BEECRYPT_CPP),y)
BEECRYPT_DEPENDENCIES += icu
BEECRYPT_CONF_OPTS += --with-cplusplus