summaryrefslogtreecommitdiff
path: root/package/berkeleydb
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2015-07-06 17:48:04 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-06 17:28:48 +0200
commit145e0d9f57f4f67973bddc8908ceacb3131b858f (patch)
treec0d43256412034cc1a1f6b9507a767f703985303 /package/berkeleydb
parenta7bc0b96233900a4f36cbb333c12ad64b03f8db9 (diff)
berkeleydb: accommodate threads presence/absence
In BerkeleyDB the most convenient implementation of mutexes on Linux is via POSIX mutex, and that requires pthread library. Still it is possible to build (and hopefully use) BerkeleyDB without mutexes. For this we pass "--disable-mutexsupport" during configuration of the package. Fixes: http://autobuild.buildroot.net/results/717f3b37600a56262badc6f7cb64d7949fdacb67/ http://autobuild.buildroot.net/results/80ebf0382992b277fd94743815bbf0c7426a3654/ Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/berkeleydb')
-rw-r--r--package/berkeleydb/berkeleydb.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/berkeleydb/berkeleydb.mk b/package/berkeleydb/berkeleydb.mk
index 30fc5182e..e5c11bddc 100644
--- a/package/berkeleydb/berkeleydb.mk
+++ b/package/berkeleydb/berkeleydb.mk
@@ -40,6 +40,7 @@ define BERKELEYDB_CONFIGURE_CMDS
$(SHARED_STATIC_LIBS_OPTS) \
--with-pic \
--enable-o_direct \
+ $(if $(BR2_TOOLCHAIN_HAS_THREADS),--enable-mutexsupport,--disable-mutexsupport) \
)
endef