summaryrefslogtreecommitdiff
path: root/package/bind
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-07-30 17:10:26 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-30 23:51:51 +0200
commit26aefa672c96caefc17adf59a9ab3d327114ad36 (patch)
treea438e9f214bd46b5b5994e0420b8a5df60a0fc3b /package/bind
parente52edcd03069788760d05f4ac934dcdbfb335474 (diff)
bind: fix static openssl linking
Apparently LIBS (environment) isn't pushed to LIBS (autoconf) for the tests, hence when static linking openssl it misses libz and assumes some basic digests required for ecdsa support are missing, which is false. Fixes: http://autobuild.buildroot.net/results/204/20411901d1bc6811e1ef8fa39457257d6bf1a146/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bind')
-rw-r--r--package/bind/bind.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index d6707d23d..e0784e66a 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -41,6 +41,8 @@ endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
BIND_DEPENDENCIES += openssl
+ BIND_CONF_ENV += ac_cv_func_EVP_sha256=yes \
+ ac_cv_func_EVP_sha384=yes ac_cv_func_EVP_sha512=yes
BIND_CONF_OPT += --with-openssl=$(STAGING_DIR)/usr LIBS="-lz" \
--with-ecdsa=yes
# GOST cipher support requires openssl extra engines