summaryrefslogtreecommitdiff
path: root/package/binutils
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-06-29 19:22:55 +0300
committerPeter Korsgaard <peter@korsgaard.com>2016-06-29 22:12:47 +0200
commit4520524ba055706236db9f00dd79f1b2e2e87fde (patch)
treef3cea99f083fe4b852e073a986c2d612ee065061 /package/binutils
parentaa34198824fd4576621af68efd0da4aca32991e1 (diff)
toolchain: Bump ARC tools to arc-2016.09-eng005
With this commit we're starting a series of updates of ARC tools. Significantly rewritten arc-2016.03 tools introduced way too many problems highlighted by Buildroot autobuilder. Now in attempt to resolve as many issues as possible by the time final release of arc-2016.09 tools is cut we'll be executing arc-2016.09 series with engineering snapshots like this one. We decided to go this way instead of applying separate patches here and there because ongoing development introduces quite a lot of changes and separate patches are not practical in Buildroot. Moreover this will give us very clean visibility of number of issues we see (hopefully it will decrease over time). One of the important changes introduced in this engineering build is initial set of changes for proper support of PIE on ARC in terms of both building on host and running on ARC target. I expect some PIE-related build breakages to go away and new ones will be treated as the high-priority issues to be fixed ASAP. For now we only update Binutils and GCC while keeping GDB as it is of arc-2016.03 release because there're some issues we'd like to resolve before releasing it to wider audience. So again note this is one of the first engineering builds of arc-2016.09 series and it might have all kinds of breakages, please don't use it for production builds. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: arc-buildroot@synopsys.com Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Peter Korsgaard <peter@korsgaard.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/binutils')
-rw-r--r--package/binutils/Config.in.host2
-rw-r--r--package/binutils/arc-2016.03/0700-Fix-issue-with-dynamic-relocs-not-being-generated-wi.patch34
-rw-r--r--package/binutils/arc-2016.09-eng005/0300-ld-makefile.patch (renamed from package/binutils/arc-2016.03/0300-ld-makefile.patch)0
-rw-r--r--package/binutils/arc-2016.09-eng005/0301-check-ldrunpath-length.patch (renamed from package/binutils/arc-2016.03/0301-check-ldrunpath-length.patch)0
-rw-r--r--package/binutils/arc-2016.09-eng005/0500-add-sysroot-fix-from-bug-3049.patch (renamed from package/binutils/arc-2016.03/0500-add-sysroot-fix-from-bug-3049.patch)0
-rw-r--r--package/binutils/arc-2016.09-eng005/0600-poison-system-directories.patch (renamed from package/binutils/arc-2016.03/0600-poison-system-directories.patch)0
-rw-r--r--package/binutils/arc-2016.09-eng005/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch (renamed from package/binutils/arc-2016.03/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch)0
-rw-r--r--package/binutils/binutils.hash2
-rw-r--r--package/binutils/binutils.mk2
9 files changed, 3 insertions, 37 deletions
diff --git a/package/binutils/Config.in.host b/package/binutils/Config.in.host
index efdc84066..0d90e3ee6 100644
--- a/package/binutils/Config.in.host
+++ b/package/binutils/Config.in.host
@@ -26,7 +26,7 @@ endchoice
config BR2_BINUTILS_VERSION
string
- default "arc-2016.03" if BR2_arc
+ default "arc-2016.09-eng005" if BR2_arc
default "2.24" if BR2_BINUTILS_VERSION_2_24_X
default "2.25.1" if BR2_BINUTILS_VERSION_2_25_X
default "2.26" if BR2_BINUTILS_VERSION_2_26_X
diff --git a/package/binutils/arc-2016.03/0700-Fix-issue-with-dynamic-relocs-not-being-generated-wi.patch b/package/binutils/arc-2016.03/0700-Fix-issue-with-dynamic-relocs-not-being-generated-wi.patch
deleted file mode 100644
index c2967a389..000000000
--- a/package/binutils/arc-2016.03/0700-Fix-issue-with-dynamic-relocs-not-being-generated-wi.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From e59d8728f2fd57938ff28bb48cb47ddc7dbf8271 Mon Sep 17 00:00:00 2001
-From: Cupertino Miranda <cmiranda@synopsys.com>
-Date: Tue, 24 May 2016 18:00:28 +0200
-Subject: [PATCH] Fix issue with dynamic relocs not being generated with -pie.
-
----
- bfd/elf32-arc.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/bfd/elf32-arc.c b/bfd/elf32-arc.c
-index c2d05e4..00af1a5 100644
---- a/bfd/elf32-arc.c
-+++ b/bfd/elf32-arc.c
-@@ -1492,7 +1492,7 @@ elf_arc_relocate_section (bfd * output_bfd,
- case R_ARC_32_ME:
- case R_ARC_PC32:
- case R_ARC_32_PCREL:
-- if (bfd_link_pic (info) && !bfd_link_pie (info)
-+ if ((bfd_link_pic (info) || bfd_link_pie (info))
- && ((r_type != R_ARC_PC32 && r_type != R_ARC_32_PCREL)
- || (h != NULL
- && h->dynindx != -1
-@@ -1774,7 +1774,7 @@ elf_arc_check_relocs (bfd * abfd,
- /* FALLTHROUGH */
- case R_ARC_PC32:
- case R_ARC_32_PCREL:
-- if (bfd_link_pic (info) && !bfd_link_pie (info)
-+ if ((bfd_link_pic (info) || bfd_link_pie (info))
- && ((r_type != R_ARC_PC32 && r_type != R_ARC_32_PCREL)
- || (h != NULL
- && h->dynindx != -1
---
-2.5.5
-
diff --git a/package/binutils/arc-2016.03/0300-ld-makefile.patch b/package/binutils/arc-2016.09-eng005/0300-ld-makefile.patch
index 73cc09802..73cc09802 100644
--- a/package/binutils/arc-2016.03/0300-ld-makefile.patch
+++ b/package/binutils/arc-2016.09-eng005/0300-ld-makefile.patch
diff --git a/package/binutils/arc-2016.03/0301-check-ldrunpath-length.patch b/package/binutils/arc-2016.09-eng005/0301-check-ldrunpath-length.patch
index 3b4c204c7..3b4c204c7 100644
--- a/package/binutils/arc-2016.03/0301-check-ldrunpath-length.patch
+++ b/package/binutils/arc-2016.09-eng005/0301-check-ldrunpath-length.patch
diff --git a/package/binutils/arc-2016.03/0500-add-sysroot-fix-from-bug-3049.patch b/package/binutils/arc-2016.09-eng005/0500-add-sysroot-fix-from-bug-3049.patch
index f67a43efd..f67a43efd 100644
--- a/package/binutils/arc-2016.03/0500-add-sysroot-fix-from-bug-3049.patch
+++ b/package/binutils/arc-2016.09-eng005/0500-add-sysroot-fix-from-bug-3049.patch
diff --git a/package/binutils/arc-2016.03/0600-poison-system-directories.patch b/package/binutils/arc-2016.09-eng005/0600-poison-system-directories.patch
index d16994ec0..d16994ec0 100644
--- a/package/binutils/arc-2016.03/0600-poison-system-directories.patch
+++ b/package/binutils/arc-2016.09-eng005/0600-poison-system-directories.patch
diff --git a/package/binutils/arc-2016.03/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch b/package/binutils/arc-2016.09-eng005/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch
index 3f072deca..3f072deca 100644
--- a/package/binutils/arc-2016.03/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch
+++ b/package/binutils/arc-2016.09-eng005/0800-Docs-Prevent-build-failures-when-makeinfo-is-missing.patch
diff --git a/package/binutils/binutils.hash b/package/binutils/binutils.hash
index 338bb8da7..b313702a0 100644
--- a/package/binutils/binutils.hash
+++ b/package/binutils/binutils.hash
@@ -4,4 +4,4 @@ sha512 0b36dda0e6d32cd25613c0e64b56b28312515c54d6a159efd3db9a86717f114ab0a0a1f6
sha512 e77e1b8dbbcbaf9ac2fae95c4403615808af3be03b2e1d32448cd3a7d32c43273f8bcace3f2de84ec120a982879295673029da306e2885dbf5f990584932cfc7 binutils-2.26.tar.bz2
# Locally calculated (fetched from Github)
-sha512 566312760ef564902fd85e281ef1370426c1451a16eb1d3e2faea7ec62100ae70ac9a5f33a7a5f87cdc744e82dd03203378fa4db1652c6b7856d865404dd19f8 binutils-arc-2016.03.tar.gz
+sha512 a0e2974990d6087aef94fec958b9f14458e847308d59dfb6f5dd8e9d1a246c4c4885a240ba43f15a7a20aff43bccba5a664daadf7fae54415bb8298620b46c23 binutils-arc-2016.09-eng005.tar.gz
diff --git a/package/binutils/binutils.mk b/package/binutils/binutils.mk
index 9ed7262eb..2fd91ba0f 100644
--- a/package/binutils/binutils.mk
+++ b/package/binutils/binutils.mk
@@ -9,7 +9,7 @@
BINUTILS_VERSION = $(call qstrip,$(BR2_BINUTILS_VERSION))
ifeq ($(BINUTILS_VERSION),)
ifeq ($(BR2_arc),y)
-BINUTILS_VERSION = arc-2016.03
+BINUTILS_VERSION = arc-2016.09-eng005
else
BINUTILS_VERSION = 2.25.1
endif