summaryrefslogtreecommitdiff
path: root/package/bluez5_utils
diff options
context:
space:
mode:
authorMike Williams <mike@mikebwilliams.com>2016-05-06 14:30:19 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-07 14:29:13 +0200
commitd732fa48d15c40ab4ffc17cddbb2a9a7378b8ce1 (patch)
tree85ebb16faa30e91e2843e5071c5f1f49ee070ba8 /package/bluez5_utils
parentfaec6b0001c2c678701896845f06e5a7e822982b (diff)
bluez5_utils: start systemd service on boot
Signed-off-by: Mike Williams <mike@mikebwilliams.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/bluez5_utils')
-rw-r--r--package/bluez5_utils/bluez5_utils.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/bluez5_utils/bluez5_utils.mk b/package/bluez5_utils/bluez5_utils.mk
index 0a7673827..659f05d58 100644
--- a/package/bluez5_utils/bluez5_utils.mk
+++ b/package/bluez5_utils/bluez5_utils.mk
@@ -79,4 +79,10 @@ else
BLUEZ5_UTILS_CONF_OPTS += --disable-systemd
endif
+define BLUEZ5_UTILS_INSTALL_INIT_SYSTEMD
+ mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/
+ ln -fs ../../../../usr/lib/systemd/system/bluetooth.service \
+ $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/bluetooth.service
+endef
+
$(eval $(autotools-package))