summaryrefslogtreecommitdiff
path: root/package/botan
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-10 17:55:23 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-04-10 22:55:00 +0200
commit7536a7354c92e0ec2760479a9d62e792703154d7 (patch)
tree6f3f2ee336d728dab71973bb9826329db42279e2 /package/botan
parent029179615e8252c112882857a7844d08cea44741 (diff)
botan: pass --prefix=/usr to fix .pc file
botan uses a non-autotools build system. We currently don't pass any --prefix=/usr, and by default the prefix is set to /usr/local. This doesn't cause a lot of visible issues because at install time, we pass DESTDIR=$(TARGET_DIR)/usr (the build system doesn't make the difference between DESTDIR and prefix). However, the generated pkg-config .pc file is wrong, as it contains prefix=/usr/local instead of prefix=/usr, which doesn't match where the botan library and headers are installed. By passing --prefix=/usr, we make sure that the .pc file is in line with where botan is installed. Fixes bug #7760 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/botan')
-rw-r--r--package/botan/botan.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/botan/botan.mk b/package/botan/botan.mk
index 70a0946d2..6ac3ce7ee 100644
--- a/package/botan/botan.mk
+++ b/package/botan/botan.mk
@@ -16,7 +16,8 @@ BOTAN_CONF_OPTS = \
--cpu=$(BR2_ARCH) \
--os=linux \
--cc=gcc \
- --cc-bin="$(TARGET_CXX)"
+ --cc-bin="$(TARGET_CXX)" \
+ --prefix=/usr
ifeq ($(BR2_STATIC_LIBS),y)
BOTAN_CONF_OPTS += --disable-shared --no-autoload