summaryrefslogtreecommitdiff
path: root/package/botan
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-10-06 19:34:57 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-10-08 00:13:13 +0200
commite43da7bb32285bbd41b38a379aef77132d149df7 (patch)
tree96b9959c2e3183880d95d7e92dd579b7002754f7 /package/botan
parent3182056e98f698c3c7ed721cc76dc69aa9dcb008 (diff)
botan: new package
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/botan')
-rw-r--r--package/botan/Config.in10
-rw-r--r--package/botan/botan.mk62
2 files changed, 72 insertions, 0 deletions
diff --git a/package/botan/Config.in b/package/botan/Config.in
new file mode 100644
index 000000000..49118723c
--- /dev/null
+++ b/package/botan/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_BOTAN
+ bool "botan"
+ depends on BR2_INSTALL_LIBSTDCPP
+ help
+ Botan is a crypto library for C++
+
+ http://botan.randombit.net
+
+comment "botan needs a toolchain w/ C++"
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/botan/botan.mk b/package/botan/botan.mk
new file mode 100644
index 000000000..ae0e02dbd
--- /dev/null
+++ b/package/botan/botan.mk
@@ -0,0 +1,62 @@
+################################################################################
+#
+# botan
+#
+################################################################################
+
+BOTAN_VERSION = 1.10.8
+BOTAN_SOURCE = Botan-$(BOTAN_VERSION).tgz
+BOTAN_SITE = http://files.randombit.net/botan
+BOTAN_LICENSE = BSD-2c
+BOTAN_LICENSE_FILES = doc/license.txt
+
+BOTAN_INSTALL_STAGING = YES
+BOTAN_INSTALL_TARGET = YES
+
+BOTAN_CONF_OPTS = \
+ --cpu=$(BR2_ARCH) \
+ --os=linux \
+ --cc=gcc \
+ --cc-bin="$(TARGET_CXX)"
+
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ BOTAN_CONF_OPTS += --disable-shared
+endif
+
+ifeq ($(BR2_PACKAGE_BZIP2),y)
+ BOTAN_DEPENDENCIES += bzip2
+ BOTAN_CONF_OPTS += --with-bzip2
+endif
+
+ifeq ($(BR2_PACKAGE_GMP),y)
+ BOTAN_DEPENDENCIES += gmp
+ BOTAN_CONF_OPTS += --with-gnump
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ BOTAN_DEPENDENCIES += openssl
+ BOTAN_CONF_OPTS += --with-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+ BOTAN_DEPENDENCIES += zlib
+ BOTAN_CONF_OPTS += --with-zlib
+endif
+
+define BOTAN_CONFIGURE_CMDS
+ (cd $(@D); ./configure.py $(BOTAN_CONF_OPTS))
+endef
+
+define BOTAN_BUILD_CMDS
+ $(MAKE) -C $(@D) AR="$(TARGET_AR) crs"
+endef
+
+define BOTAN_INSTALL_STAGING_CMDS
+ $(MAKE) -C $(@D) DESTDIR="$(STAGING_DIR)/usr" install
+endef
+
+define BOTAN_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)/usr" install
+endef
+
+$(eval $(generic-package))