summaryrefslogtreecommitdiff
path: root/package/botan
diff options
context:
space:
mode:
authorFrancois Perrad <fperrad@gmail.com>2014-11-27 07:35:07 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-11-27 22:48:09 +0100
commitf824d3e2bebfab9ae746e605b65a852c68f55152 (patch)
tree7e5cc2252d2389603645c4719870e9767079ab9d /package/botan
parent3e0440407aa276983439ee1bdf82903d679fb5a7 (diff)
botan: fix static build
see http://autobuild.buildroot.net/results/2d1/2d1563e253b669b45c9df449c5b3a750c04a43dc/ this commit reverts the previous commit 84047394ed6ad08adb9f59a9022553a327eef040 which disables static build in Config.in the option --no-autoload prevents the use of the function dlopen. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/botan')
-rw-r--r--package/botan/Config.in5
-rw-r--r--package/botan/botan.mk2
2 files changed, 3 insertions, 4 deletions
diff --git a/package/botan/Config.in b/package/botan/Config.in
index c82a77fb2..733dc8965 100644
--- a/package/botan/Config.in
+++ b/package/botan/Config.in
@@ -10,12 +10,11 @@ config BR2_PACKAGE_BOTAN
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_PACKAGE_BOTAN_ARCH_SUPPORTS
- depends on !BR2_PREFER_STATIC_LIB # dlfcn.h
help
Botan is a crypto library for C++
http://botan.randombit.net
-comment "botan needs a toolchain w/ C++, threads, dynamic library"
- depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP || BR2_PREFER_STATIC_LIB
+comment "botan needs a toolchain w/ C++, threads"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP
depends on BR2_PACKAGE_BOTAN_ARCH_SUPPORTS
diff --git a/package/botan/botan.mk b/package/botan/botan.mk
index ae0e02dbd..2e47eb6e8 100644
--- a/package/botan/botan.mk
+++ b/package/botan/botan.mk
@@ -20,7 +20,7 @@ BOTAN_CONF_OPTS = \
--cc-bin="$(TARGET_CXX)"
ifeq ($(BR2_PREFER_STATIC_LIB),y)
- BOTAN_CONF_OPTS += --disable-shared
+ BOTAN_CONF_OPTS += --disable-shared --no-autoload
endif
ifeq ($(BR2_PACKAGE_BZIP2),y)