summaryrefslogtreecommitdiff
path: root/package/busybox
diff options
context:
space:
mode:
authorMatt Weber <Matthew.Weber@rockwellcollins.com>2015-07-14 15:20:19 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-18 15:06:41 +0200
commit083aeac94e19cde6abd4b29cf29db589327d8c49 (patch)
tree00d898c80933f0dea1bb8be9223500811156390c /package/busybox
parentb0b3dc5612a012dd29293bee0cd848aa1b7c0b7d (diff)
busybox: added linux-pam support
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 65ce7efe9..ce6652b01 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -141,6 +141,13 @@ define BUSYBOX_SET_INIT
endef
endif
+ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+define BUSYBOX_LINUX_PAM
+ $(call KCONFIG_ENABLE_OPT,CONFIG_PAM,$(BUSYBOX_BUILD_CONFIG))
+endef
+BUSYBOX_DEPENDENCIES += linux-pam
+endif
+
ifeq ($(BR2_PACKAGE_BUSYBOX_SELINUX),y)
BUSYBOX_DEPENDENCIES += host-pkgconf libselinux libsepol
define BUSYBOX_SET_SELINUX