summaryrefslogtreecommitdiff
path: root/package/busybox
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-07-13 12:32:03 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-14 10:31:11 +0200
commit3ff5f63e48237cf569aaba6be35e179bf8556a19 (patch)
treefcab0da1f429f7528ed6651ccf6f85c1fcf1b1bd /package/busybox
parent06d126fdc1813dad84c95c2500f400f45853ffae (diff)
package/busybox: check for config file
Add a check (before we call kconfig-package) that ensures the user has set a kconfig-file. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index aab7f5d57..d8c8bad31 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -223,4 +223,12 @@ define BUSYBOX_INSTALL_INIT_SYSV
$(BUSYBOX_INSTALL_TELNET_SCRIPT)
endef
+# Checks to give errors that the user can understand
+# Must be before we call to kconfig-package
+ifeq ($(BR_BUILDING),y)
+ifeq ($(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG)),)
+$(error No BusyBox configuration file specified, check your BR2_PACKAGE_BUSYBOX_CONFIG setting)
+endif
+endif
+
$(eval $(kconfig-package))