summaryrefslogtreecommitdiff
path: root/package/busybox
diff options
context:
space:
mode:
authorGilles Chanteperdrix <gilles.chanteperdrix@xenomai.org>2016-11-23 13:58:46 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-23 22:56:53 +0100
commita8254d32fd839ebd0a96863579832678eb6e0038 (patch)
treed824a73e2249c34e8da4303ec93e60ff2bb6acf3 /package/busybox
parentaf109fb44469a89b2576d167b02f02a811d13c12 (diff)
busybox: disable build timestamps for reproducible builds
Busybox includes some information about the build environment in its binary. For BR2_REPRODUCIBLE, remove that information. Signed-off-by: Gilles Chanteperdrix <gilles.chanteperdrix@xenomai.org> Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/busybox.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index fc23a90a2..f4a241d38 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -36,6 +36,12 @@ BUSYBOX_MAKE_ENV = \
$(TARGET_MAKE_ENV) \
CFLAGS="$(BUSYBOX_CFLAGS)" \
CFLAGS_busybox="$(BUSYBOX_CFLAGS_busybox)"
+
+ifeq ($(BR2_REPRODUCIBLE),y)
+BUSYBOX_MAKE_ENV += \
+ KCONFIG_NOTIMESTAMP=1
+endif
+
BUSYBOX_MAKE_OPTS = \
CC="$(TARGET_CC)" \
ARCH=$(KERNEL_ARCH) \