summaryrefslogtreecommitdiff
path: root/package/ca-certificates
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-04-03 01:09:06 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-03 15:39:39 +0200
commitea6b7bd5455e733c9fb006c7ed3103459b62d0fe (patch)
treee4d4fc4a1bc0454d3c32036b6c59fd5b538deb9c /package/ca-certificates
parent6947697783e85bc032cffefb103965e954645602 (diff)
package/ca-certificates: generate the bundle of certs
glib-networking wants to use the certificates bundle, not the individual certificates. Generating the bundle is usually done with update-ca-certificates, but that does not support running out-of-tree. Fortiunately, and as Gustavo put it, update-ca-certificates is jsut a glorified 'cat'. It is supposed to be fed a config file stating which certificate to add/remove to/from the bundle, otherwise nothing fancy (Oh, yes, running hooks after updating the bundle). Since we do not need any of this in Buidlroot, we jsut generate a bundle with all certificates unconditionally. Reported-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ca-certificates')
-rw-r--r--package/ca-certificates/ca-certificates.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/ca-certificates/ca-certificates.mk b/package/ca-certificates/ca-certificates.mk
index 271985a51..8fe26c99c 100644
--- a/package/ca-certificates/ca-certificates.mk
+++ b/package/ca-certificates/ca-certificates.mk
@@ -25,9 +25,11 @@ define CA_CERTIFICATES_INSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/etc/ssl/certs/*
# Create symlinks to certificates under /etc/ssl/certs
+ # and generate the bundle
cd $(TARGET_DIR) ;\
for i in `find usr/share/ca-certificates -name "*.crt"` ; do \
ln -sf ../../../$$i etc/ssl/certs/`basename $${i} .crt`.pem ;\
+ cat $$i >>etc/ssl/certs/ca-certificates.crt ;\
done
# Create symlinks to the certificates by their hash values