summaryrefslogtreecommitdiff
path: root/package/cairo
diff options
context:
space:
mode:
authorHadrien Boutteville <hadrien.boutteville@gmail.com>2014-07-08 15:57:06 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-15 23:19:42 +0200
commit1612fd39e11556f2f672f2f0e8444b025c56e2d4 (patch)
tree10e6974b91db7d2034d792f0b74858df0710f137 /package/cairo
parent08d3ec14d4250caa487d2f144c3deea85479e6d3 (diff)
cairo: add freetype and gobject support
Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cairo')
-rw-r--r--package/cairo/cairo.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index 789dfa7ba..a4c71b681 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -55,6 +55,20 @@ else
CAIRO_CONF_OPT += --disable-directfb
endif
+ifeq ($(BR2_PACKAGE_FREETYPE),y)
+ CAIRO_CONF_OPT += --enable-ft
+ CAIRO_DEPENDENCIES += freetype
+else
+ CAIRO_CONF_OPT += --disable-ft
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+ CAIRO_CONF_OPT += --enable-gobject
+ CAIRO_DEPENDENCIES += libglib2
+else
+ CAIRO_CONF_OPT += --disable-gobject
+endif
+
ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
CAIRO_CONF_OPT += --enable-glesv2
CAIRO_DEPENDENCIES += libgles