summaryrefslogtreecommitdiff
path: root/package/cairo
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-21 15:47:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-21 16:04:14 +0100
commitc6954be55400d16477f256e7841a8b45972e2d9e (patch)
treee0bb19f2aaa32bccdde3639cdbbdb9a1e7788d80 /package/cairo
parent1811fd8cb1c681d1ff59dacb1c65992190ef926e (diff)
package/cairo: add optional support for lzo
When lzo was compiled before, cairo will use it as optional dependency: $ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/cairo-sphinx | grep NEEDED | sort [...] 0x0000000000000001 (NEEDED) Shared library: [liblzo2.so.2] The build system offers no option to en-/disable lzo support: https://cgit.freedesktop.org/cairo/tree/configure.ac#n54 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cairo')
-rw-r--r--package/cairo/cairo.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index 205250d95..6b54b286e 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -93,6 +93,10 @@ else
CAIRO_CONF_OPTS += --disable-vg
endif
+ifeq ($(BR2_PACKAGE_LZO),y)
+CAIRO_DEPENDENCIES += lzo
+endif
+
ifeq ($(BR2_PACKAGE_XORG7),y)
CAIRO_CONF_OPTS += --enable-xlib --enable-xcb --with-x
CAIRO_DEPENDENCIES += xlib_libX11 xlib_libXext