summaryrefslogtreecommitdiff
path: root/package/cairo
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openadk.org>2016-08-08 06:46:17 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-08 23:46:54 +0200
commitfd4f715268df5fbfc14e6ea8a54fd5de70b6a947 (patch)
treebe3858d0bb10ef46145a2cac8ba4f351363a2de7 /package/cairo
parent72b75c428dfaa7e8de77d776e677fb0a009df486 (diff)
cairo: fix m68k uclinux compile
The GCC manual suggest when getting: relocation truncated to fit: R_68K_GOT16O foobar to use -mxgot. Fixes: http://autobuild.buildroot.net/results/31a488316fe3c14729a6dd9259205f8530684cab/ http://autobuild.buildroot.net/results/dc6b899e3e502d65b2cf2f6d922a4f63857edf82/ Signed-off-by: Waldemar Brodkorb <wbx@openadk.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cairo')
-rw-r--r--package/cairo/cairo.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/cairo/cairo.mk b/package/cairo/cairo.mk
index b79899565..d7e370ae7 100644
--- a/package/cairo/cairo.mk
+++ b/package/cairo/cairo.mk
@@ -12,6 +12,11 @@ CAIRO_SITE = http://cairographics.org/releases
CAIRO_INSTALL_STAGING = YES
CAIRO_AUTORECONF = YES
+# relocation truncated to fit: R_68K_GOT16O
+ifeq ($(BR2_m68k_cf),y)
+CAIRO_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
+endif
+
ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
CAIRO_CONF_ENV += CPPFLAGS="$(TARGET_CPPFLAGS) -DCAIRO_NO_MUTEX=1"
endif