summaryrefslogtreecommitdiff
path: root/package/cc-tool
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-05 23:36:45 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-05-07 22:21:33 +0200
commit4051756ad45452a5a949835fb39544d4e425721a (patch)
treee8067e0962105db821785e0dc1f2ab92a3223512 /package/cc-tool
parentb6b38f525f91d18cda9d570a776655b646e8b0aa (diff)
cc-tool: fix static build problem with boost regex
The boost.m4 logic is a bit crappy, and needs some help to know that boost_regex needs the pthread library. Fixes: http://autobuild.buildroot.org/results/69a/69aff0b9d0ac8fe08e1d2f7ffb691f6a8fc8693b/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/cc-tool')
-rw-r--r--package/cc-tool/cc-tool.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/cc-tool/cc-tool.mk b/package/cc-tool/cc-tool.mk
index 7312bd384..3a3f85ac4 100644
--- a/package/cc-tool/cc-tool.mk
+++ b/package/cc-tool/cc-tool.mk
@@ -14,4 +14,10 @@ CC_TOOL_DEPENDENCIES = boost libusb
# Configure script "discovers" boost in /usr/local if not given explicitly
CC_TOOL_CONF_OPTS = --with-boost=$(STAGING_DIR)/usr
+# Help boost.m4 find the Boost Regex library, which needs the pthread
+# library, but isn't detected using a modern (pkg-config) mechanism.
+ifeq ($(BR2_STATIC_LIBS),y)
+CC_TOOL_CONF_ENV += LIBS="-lpthread"
+endif
+
$(eval $(autotools-package))