summaryrefslogtreecommitdiff
path: root/package/ccache
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2014-04-30 22:05:06 -0400
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-06-14 19:59:07 +0200
commitd93a0b402934309c632d4a825b7fe6183ce8c4c7 (patch)
treeebc0d14ac857490b542197d13fc681016909f282 /package/ccache
parent8f9da282b299c667a20b636d7512144283fd92c0 (diff)
ccache: change default cache directory path to match config setting
Commit 433290761fceb476b095548eec10adf72405e050 changed the hard-coded ccache directory location to use BR_CACHE_DIR (then BUILDROOT_CACHE_DIR), which is exported by Makefile based on the BR2_CCACHE_DIR config option. This allowed the cache location to be changed on-the-fly by setting a "make" command line variable, but left the default location of ccache's normal default at "$HOME/.ccache". Since this location does not match the default for BR2_CCACHE_DIR, it is basically almost never correct, so direct invocation of ccache outside of the buildroot Makefile, such as for increasing the cache size, becomes cumbersome. This patch changes the last-ditch cache location from "$HOME/.ccache" to the BR_CCACHE_DIR value defined when host-ccache is configured. Note that the ability to later override the cache location by using a BR_CACHE_DIR command line variable is left intact. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Tested-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ccache')
-rw-r--r--package/ccache/ccache.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/ccache/ccache.mk b/package/ccache/ccache.mk
index 650290dce..df92c5e99 100644
--- a/package/ccache/ccache.mk
+++ b/package/ccache/ccache.mk
@@ -30,9 +30,12 @@ HOST_CCACHE_CONF_OPT += ccache_cv_zlib_1_2_3=no
# the compiler, because in the context of Buildroot, that completely
# defeats the purpose of ccache. Of course, that leaves the user
# responsible for purging its cache when the compiler changes.
+# - Change hard-coded last-ditch default to match path in .config, to avoid
+# the need to specify BR_CACHE_DIR when invoking ccache directly.
define HOST_CCACHE_PATCH_CONFIGURATION
sed -i 's,getenv("CCACHE_DIR"),getenv("BR_CACHE_DIR"),' $(@D)/ccache.c
sed -i 's,getenv("CCACHE_COMPILERCHECK"),"none",' $(@D)/ccache.c
+ sed -i 's,"%s/.ccache","$(BR_CACHE_DIR)",' $(@D)/ccache.c
endef
HOST_CCACHE_POST_CONFIGURE_HOOKS += \