summaryrefslogtreecommitdiff
path: root/package/check
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>2015-09-19 09:41:51 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-09-19 15:07:33 +0200
commit9878cec4e49344a0520ecac02bd84e1a98e17c24 (patch)
treeb296ea470cd9c1e866087fbf80e402a829e56df4 /package/check
parent87f3edecc65975085982515f3618c81bcfd9c023 (diff)
check: new package
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/check')
-rw-r--r--package/check/Config.in6
-rw-r--r--package/check/check.hash3
-rw-r--r--package/check/check.mk20
3 files changed, 29 insertions, 0 deletions
diff --git a/package/check/Config.in b/package/check/Config.in
new file mode 100644
index 000000000..04682e148
--- /dev/null
+++ b/package/check/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_CHECK
+ bool "check"
+ help
+ Check is a unit testing framework for C.
+
+ http://check.sourceforge.net/
diff --git a/package/check/check.hash b/package/check/check.hash
new file mode 100644
index 000000000..0c3a924b5
--- /dev/null
+++ b/package/check/check.hash
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/check/files/check/0.10.0/
+md5 53c5e5c77d090e103a17f3ed7fd7d8b8 check-0.10.0.tar.gz
+sha1 35d3a53446aea7b21a770faedb358d0fc7cba76d check-0.10.0.tar.gz
diff --git a/package/check/check.mk b/package/check/check.mk
new file mode 100644
index 000000000..92dd03365
--- /dev/null
+++ b/package/check/check.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# check
+#
+################################################################################
+
+CHECK_VERSION = 0.10.0
+CHECK_SITE = http://downloads.sourceforge.net/project/check/check/$(CHECK_VERSION)
+CHECK_INSTALL_STAGING = YES
+CHECK_DEPENDENCIES = host-pkgconf
+CHECK_LICENSE = LGPLv2.1+
+CHECK_LICENSE_FILES = COPYING.LESSER
+
+# Having checkmk in the target makes no sense
+define CHECK_REMOVE_CHECKMK
+ rm -f $(TARGET_DIR)/usr/bin/checkmk
+endef
+CHECK_POST_INSTALL_TARGET_HOOKS += CHECK_REMOVE_CHECKMK
+
+$(eval $(autotools-package))