summaryrefslogtreecommitdiff
path: root/package/checkpolicy
diff options
context:
space:
mode:
authorClayton Shotwell <clshotwe@rockwellcollins.com>2015-01-07 11:10:36 -0600
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-08 22:58:52 +0100
commit37d78971061754b9101a9e19739ce4906ae29506 (patch)
tree4ed5270b7261d3ed725632112a03dabd0cb018d5 /package/checkpolicy
parent611523d825d65b500588a3e03b9a5c375f3e2d21 (diff)
checkpolicy: new package
[Thomas: - Indicate in the Config.in help text that this policy compiler is SELinux related. - Rewrap Config.in help text and remove trailing white space. - Add a comment in the .mk file to indicate why we're passing DESTDIR= at build time.] Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com> Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/checkpolicy')
-rw-r--r--package/checkpolicy/Config.in.host10
-rw-r--r--package/checkpolicy/checkpolicy.hash2
-rw-r--r--package/checkpolicy/checkpolicy.mk27
3 files changed, 39 insertions, 0 deletions
diff --git a/package/checkpolicy/Config.in.host b/package/checkpolicy/Config.in.host
new file mode 100644
index 000000000..240a5b6dc
--- /dev/null
+++ b/package/checkpolicy/Config.in.host
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_HOST_CHECKPOLICY
+ bool "host checkpolicy"
+ help
+ checkpolicy is the SELinux policy compiler. It uses libsepol
+ to generate the binary policy. checkpolicy uses the static
+ libsepol since it deals with low level details of the policy
+ that have not been encapsulated/abstracted by a proper
+ shared library interface.
+
+ http://selinuxproject.org/page/Main_Page
diff --git a/package/checkpolicy/checkpolicy.hash b/package/checkpolicy/checkpolicy.hash
new file mode 100644
index 000000000..32b5ff620
--- /dev/null
+++ b/package/checkpolicy/checkpolicy.hash
@@ -0,0 +1,2 @@
+# https://github.com/SELinuxProject/selinux/wiki/Releases
+sha256 e6a0ac539b74859b4262b317eb90d9914deb15e7aa509659f47724d50fe2ecc6 checkpolicy-2.1.12.tar.gz
diff --git a/package/checkpolicy/checkpolicy.mk b/package/checkpolicy/checkpolicy.mk
new file mode 100644
index 000000000..4b7b2f342
--- /dev/null
+++ b/package/checkpolicy/checkpolicy.mk
@@ -0,0 +1,27 @@
+################################################################################
+#
+# checkpolicy
+#
+################################################################################
+
+CHECKPOLICY_VERSION = 2.1.12
+CHECKPOLICY_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20130423
+CHECKPOLICY_LICENSE = GPLv2
+CHECKPOLICY_LICENSE_FILES = COPYING
+
+HOST_CHECKPOLICY_DEPENDENCIES = host-libselinux host-flex host-bison
+
+HOST_CHECKPOLICY_MAKE_OPTS = $(HOST_CONFIGURE_OPTS) \
+ LEX="$(HOST_DIR)/usr/bin/flex" \
+ YACC="$(HOST_DIR)/usr/bin/bison -y"
+
+# DESTDIR is used at build time to find host-libselinux
+define HOST_CHECKPOLICY_BUILD_CMDS
+ $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS) DESTDIR=$(HOST_DIR)
+endef
+
+define HOST_CHECKPOLICY_INSTALL_CMDS
+ $(MAKE) -C $(@D) $(HOST_CHECKPOLICY_MAKE_OPTS) DESTDIR=$(HOST_DIR) install
+endef
+
+$(eval $(host-generic-package))