summaryrefslogtreecommitdiff
path: root/package/chrony
diff options
context:
space:
mode:
authorJames Knight <james.knight@rockwellcollins.com>2016-11-18 15:26:31 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-26 14:59:36 +0100
commit40a60b7545beea2d1ea852481cbf779d740e1d66 (patch)
tree37e541269720755d4f4f43c79ab46d014324eda4 /package/chrony
parent83e207d7bc52fbcb38b33dc387f37da333d3e248 (diff)
chrony: enable pps support
Chrony has the ability to support PPS. Its enablement is determined primarily from the existence of `sys/timepps.h`. This file is provided from the pps-tools package. Adjusting Chrony's Makefile to depend on the pps-tools package if a developer has included pps-tools as part of a build. Relates to 2cfc966f431c7c715b3fc11ca0467d47432fca33. Signed-off-by: James Knight <james.knight@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/chrony')
-rw-r--r--package/chrony/chrony.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/chrony/chrony.mk b/package/chrony/chrony.mk
index adfbd3664..5f3160e19 100644
--- a/package/chrony/chrony.mk
+++ b/package/chrony/chrony.mk
@@ -34,6 +34,12 @@ else
CHRONY_CONF_OPTS += --disable-readline
endif
+# If pps-tools is available, build it before so the package can use it
+# (HAVE_SYS_TIMEPPS_H).
+ifeq ($(BR2_PACKAGE_PPS_TOOLS),y)
+CHRONY_DEPENDENCIES += pps-tools
+endif
+
define CHRONY_CONFIGURE_CMDS
cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure $(CHRONY_CONF_OPTS)
endef