summaryrefslogtreecommitdiff
path: root/package/circus
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-07-05 16:41:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-05 17:26:35 +0200
commit739e64e6ea98db2c6a05c04a631c75745f225895 (patch)
treeb4aed287f533695278a1d0d6fd6869bdd3751834 /package/circus
parent246c9918911c6faf9b505a474c3500a7f9671882 (diff)
circus: new package
Reviewed-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: minor tweaks to Config.in.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/circus')
-rw-r--r--package/circus/Config.in21
-rw-r--r--package/circus/circus.hash3
-rw-r--r--package/circus/circus.mk14
3 files changed, 38 insertions, 0 deletions
diff --git a/package/circus/Config.in b/package/circus/Config.in
new file mode 100644
index 000000000..e696f251d
--- /dev/null
+++ b/package/circus/Config.in
@@ -0,0 +1,21 @@
+config BR2_PACKAGE_CIRCUS
+ bool "circus"
+ depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
+ depends on BR2_USE_WCHAR # pyzmq -> zeromq
+ depends on BR2_INSTALL_LIBSTDCPP # pyzmq -> zeromq
+ depends on BR2_TOOLCHAIN_HAS_THREADS # pyzmq -> zeromq
+ select BR2_PACKAGE_PYTHON_IOWAIT # runtime
+ select BR2_PACKAGE_PYTHON_PSUTIL # runtime
+ select BR2_PACKAGE_PYTHON_PYZMQ # runtime
+ select BR2_PACKAGE_PYTHON_TORNADO # runtime
+ select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
+ help
+ Circus is a program that will let you run and watch multiple
+ processes and sockets.
+
+ https://circus.readthedocs.org/en/latest/
+
+comment "circus needs Python and a toolchain w/ C++, wchar, threads"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+ !BR2_TOOLCHAIN_HAS_THREADS || \
+ !(BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3)
diff --git a/package/circus/circus.hash b/package/circus/circus.hash
new file mode 100644
index 000000000..728cad523
--- /dev/null
+++ b/package/circus/circus.hash
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/circus/json, sha256 locally computed
+md5 cddd4a8844907d8b6b402ca9c713d176 circus-0.13.0.tar.gz
+sha256 6201800a5fb05144b5e6c5ac9eb901b914305e8beaeb01f8edf54ab6ab1a295a circus-0.13.0.tar.gz
diff --git a/package/circus/circus.mk b/package/circus/circus.mk
new file mode 100644
index 000000000..a7693bdf5
--- /dev/null
+++ b/package/circus/circus.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# circus
+#
+################################################################################
+
+CIRCUS_VERSION = 0.13.0
+CIRCUS_SOURCE = circus-$(CIRCUS_VERSION).tar.gz
+CIRCUS_SITE = https://pypi.python.org/packages/source/c/circus
+CIRCUS_SETUP_TYPE = setuptools
+CIRCUS_LICENSE = Apache-2.0
+CIRCUS_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))