summaryrefslogtreecommitdiff
path: root/package/civetweb
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2013-12-31 11:07:31 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-31 11:57:54 +0100
commit37084ead509fa42db39637fcb837e7a99197c6c9 (patch)
tree1d73703a4eaada56f0dfbbcbbfe710b63109c0c4 /package/civetweb
parent7c04932603476f3adf474f3bc47c35bdb59d947a (diff)
civetweb: fix build for xtensa
The civetweb package bundled sqlite3 generates an object that is too large for the xtensa default placement of literals in a dedicated section. Use -mtext-section-literal to place literals in the text section. Fixes http://autobuild.buildroot.net/results/d14/d142f3ce17ab22cc39f9117c114318c1b5cadfc5/. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/civetweb')
-rw-r--r--package/civetweb/civetweb.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/civetweb/civetweb.mk b/package/civetweb/civetweb.mk
index 4c8f4e88f..b95089060 100644
--- a/package/civetweb/civetweb.mk
+++ b/package/civetweb/civetweb.mk
@@ -25,6 +25,9 @@ endif
ifeq ($(BR2_CIVETWEB_WITH_LUA),y)
CIVETWEB_CONF_OPT += WITH_LUA=1
+ifeq ($(BR2_xtensa),y)
+ CIVETWEB_COPT += -mtext-section-literals
+endif
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)