summaryrefslogtreecommitdiff
path: root/package/collectd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2017-01-10 10:06:46 -0300
committerPeter Korsgaard <peter@korsgaard.com>2017-01-10 21:07:30 +0100
commit01cd62a31c2e04ea9acaca9cfca527a938e40e85 (patch)
tree96cbc28e5204c769ce548168e1d22ada9220da54 /package/collectd
parenta50e9b95bf46372fc74a84528ba2ac7e72214d16 (diff)
collectd: fix libgcrypt support
For the newer versions the collectd configure script expects libgcrypt-config as parameter rather than the location for the libgcrypt-config script. Adjust the package to account for this. Fixes: http://autobuild.buildroot.net/results/a49/a494bc905e4509528c4932f76a094b9ea8e70bd3/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/collectd')
-rw-r--r--package/collectd/collectd.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index 7ab7dd422..fa6ebae71 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -175,8 +175,7 @@ endif
# network can use libgcrypt
ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
COLLECTD_DEPENDENCIES += libgcrypt
-COLLECTD_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr
-COLLECTD_CONF_ENV += LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
+COLLECTD_CONF_OPTS += --with-libgcrypt=$(STAGING_DIR)/usr/bin/libgcrypt-config
else
COLLECTD_CONF_OPTS += --with-libgcrypt=no
endif