summaryrefslogtreecommitdiff
path: root/package/collectd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-12-21 22:59:14 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-12-23 22:37:31 +0100
commit0c48707f48715e744b8bb3fd03d40509147c6aab (patch)
tree86e7a3108fd9901c80bbfd7f3e4a4ba127eff491 /package/collectd
parent81456f1e920076270b0c6aeac99c3e51fe81325d (diff)
collectd: add cpusleep plugin support
Add explicit support for the new cpusleep dependency-less plugin. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/collectd')
-rw-r--r--package/collectd/Config.in5
-rw-r--r--package/collectd/collectd.mk1
2 files changed, 6 insertions, 0 deletions
diff --git a/package/collectd/Config.in b/package/collectd/Config.in
index 5e84aa5c5..d1b85aadb 100644
--- a/package/collectd/Config.in
+++ b/package/collectd/Config.in
@@ -157,6 +157,11 @@ config BR2_PACKAGE_COLLECTD_CPUFREQ
help
Collects the current CPU's frequency.
+config BR2_PACKAGE_COLLECTD_CPUSLEEP
+ bool "cpusleep"
+ help
+ Measures time spent by CPU in deep sleep mode.
+
config BR2_PACKAGE_COLLECTD_CURL
bool "curl"
select BR2_PACKAGE_LIBCURL
diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index 5018fb062..d8b2576c9 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -41,6 +41,7 @@ COLLECTD_CONF_OPTS += \
$(if $(BR2_PACKAGE_COLLECTD_CONTEXTSWITCH),--enable-contextswitch,--disable-contextswitch) \
$(if $(BR2_PACKAGE_COLLECTD_CPU),--enable-cpu,--disable-cpu) \
$(if $(BR2_PACKAGE_COLLECTD_CPUFREQ),--enable-cpufreq,--disable-cpufreq) \
+ $(if $(BR2_PACKAGE_COLLECTD_CPUSLEEP),--enable-cpusleep,--disable-cpusleep) \
$(if $(BR2_PACKAGE_COLLECTD_CSV),--enable-csv,--disable-csv) \
$(if $(BR2_PACKAGE_COLLECTD_CURL),--enable-curl,--disable-curl) \
$(if $(BR2_PACKAGE_COLLECTD_CURL_JSON),--enable-curl_json,--disable-curl_json) \