summaryrefslogtreecommitdiff
path: root/package/collectd
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-12-21 22:59:09 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-12-23 22:32:21 +0100
commit8d6dd49e60250f788c3d35b3982c3b0252143d56 (patch)
tree7ca7b909c35b12eea85193dcf6fac46f3feef6c1 /package/collectd
parentb6f66b0c532e706852b2a0694dab4b6ca3db8402 (diff)
collectd: add notify_nagios plugin support
Add explicit support for the new notify_nagios dependency-less plugin. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/collectd')
-rw-r--r--package/collectd/Config.in5
-rw-r--r--package/collectd/collectd.mk1
2 files changed, 6 insertions, 0 deletions
diff --git a/package/collectd/Config.in b/package/collectd/Config.in
index 6405af6a8..72e57931a 100644
--- a/package/collectd/Config.in
+++ b/package/collectd/Config.in
@@ -75,6 +75,11 @@ config BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL
comment "notify_email needs a toolchain w/ dynamic library"
depends on BR2_STATIC_LIBS
+config BR2_PACKAGE_COLLECTD_NOTIFY_NAGIOS
+ bool "notify_nagios"
+ help
+ Sends notifications to Nagios as a passive check result.
+
config BR2_PACKAGE_COLLECTD_SYSLOG
bool "syslog"
default y
diff --git a/package/collectd/collectd.mk b/package/collectd/collectd.mk
index ccb2f1133..942ba3889 100644
--- a/package/collectd/collectd.mk
+++ b/package/collectd/collectd.mk
@@ -77,6 +77,7 @@ COLLECTD_CONF_OPTS += \
$(if $(BR2_PACKAGE_COLLECTD_NGINX),--enable-nginx,--disable-nginx) \
$(if $(BR2_PACKAGE_COLLECTD_NOTIFICATION),--enable-target_notification,--disable-target_notification) \
$(if $(BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL),--enable-notify_email,--disable-notify_email) \
+ $(if $(BR2_PACKAGE_COLLECTD_NOTIFY_NAGIOS),--enable-notify_nagios,--disable-notify_nagios) \
$(if $(BR2_PACKAGE_COLLECTD_NTPD),--enable-ntpd,--disable-ntpd) \
$(if $(BR2_PACKAGE_COLLECTD_OLSRD),--enable-olsrd,--disable-olsrd) \
$(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),--enable-openldap,--disable-openldap) \