summaryrefslogtreecommitdiff
path: root/package/coreutils
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-11-07 09:45:46 -0300
committerPeter Korsgaard <peter@korsgaard.com>2014-11-07 14:33:02 +0100
commitef5c3f4e89c91597f1748b8877c1e3dd5c77c28b (patch)
tree0a917db9a0bb913e591291628965c7bce14c98e5 /package/coreutils
parentd402daaeaef5be2574768c1e2c495ed38a190cea (diff)
coreutils: fix build failure for musl
musl doesn't implement re_match and friends and coreutils fails to detect this properly, so force internal regex routines for musl. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index 41857e2ec..391d2cd40 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -14,7 +14,8 @@ COREUTILS_LICENSE_FILES = COPYING
COREUTILS_AUTORECONF = YES
COREUTILS_GETTEXTIZE = YES
-COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs
+COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs \
+ $(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
ac_cv_func_chown_works=yes \
ac_cv_func_euidaccess=no \