summaryrefslogtreecommitdiff
path: root/package/cpio
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-08-08 00:47:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-08 11:16:04 +0200
commit7d53040f330e68d3ddb611b73e3c8098552ab612 (patch)
tree816906145f107f2bdef9756850dbb0b57a8968ac /package/cpio
parent6b47541e5ed62a9ec1f95ef4f03bedbd417b33e6 (diff)
package/cpio: add argp-standalone dependency with musl
Since argp-standalone is only available for uClibc-ng and musl toolchains, add the dependendy only if it's selected. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cpio')
-rw-r--r--package/cpio/Config.in2
-rw-r--r--package/cpio/cpio.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/cpio/Config.in b/package/cpio/Config.in
index df40faccf..1210a0bde 100644
--- a/package/cpio/Config.in
+++ b/package/cpio/Config.in
@@ -1,7 +1,7 @@
config BR2_PACKAGE_CPIO
bool "cpio"
# Need argp.h support
- select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+ select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
depends on BR2_USE_WCHAR
help
cpio archive utility for creation and extraction.
diff --git a/package/cpio/cpio.mk b/package/cpio/cpio.mk
index aa9daced1..e18af8140 100644
--- a/package/cpio/cpio.mk
+++ b/package/cpio/cpio.mk
@@ -15,10 +15,10 @@ CPIO_PATCH = \
https://projects.archlinux.org/svntogit/packages.git/plain/cpio/trunk/cpio-2.11-check_for_symlinks-CVE-2015-1197.patch \
https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-arch/cpio/files/cpio-2.11-stat.patch
-# cpio uses argp.h which is not provided by uclibc by default.
+# cpio uses argp.h which is not provided by uclibc or musl by default.
# Use the argp-standalone package to provide this but make sure
# the host package does not try to use the host version.
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
CPIO_DEPENDENCIES += argp-standalone
endif