summaryrefslogtreecommitdiff
path: root/package/crda
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-03 22:41:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-12-11 22:48:13 +0100
commit665e13c85e1fd216499cdd335a88a4d1c20f175f (patch)
tree5ecc87c54905105b96cbe9891028ef8eb3d713b1 /package/crda
parent2d23d40279be39f70553974de11a5fc088622911 (diff)
Rename BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS
Since a while, the semantic of BR2_PREFER_STATIC_LIB has been changed from "prefer static libraries when possible" to "use only static libraries". The former semantic didn't make much sense, since the user had absolutely no control/idea of which package would use static libraries, and which packages would not. Therefore, for quite some time, we have been starting to enforce that BR2_PREFER_STATIC_LIB should really build everything with static libraries. As a consequence, this patch renames BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS, and adjust the Config.in option accordingly. This also helps preparing the addition of other options to select shared, shared+static or just static. Note that we have verified that this commit can be reproduced by simply doing a global rename of BR2_PREFER_STATIC_LIB to BR2_STATIC_LIBS plus adding BR2_PREFER_STATIC_LIB to Config.in.legacy. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'package/crda')
-rw-r--r--package/crda/Config.in4
-rw-r--r--package/crda/crda.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/crda/Config.in b/package/crda/Config.in
index 4d01530d8..5318fc1de 100644
--- a/package/crda/Config.in
+++ b/package/crda/Config.in
@@ -1,7 +1,7 @@
config BR2_PACKAGE_CRDA
bool "crda"
depends on BR2_TOOLCHAIN_HAS_THREADS # libnl
- depends on !BR2_PREFER_STATIC_LIB
+ depends on !BR2_STATIC_LIBS
select BR2_PACKAGE_LIBGCRYPT
select BR2_PACKAGE_LIBNL
# regdb is a runtime dependency
@@ -20,6 +20,6 @@ config BR2_PACKAGE_CRDA
http://linuxwireless.org/en/developers/Regulatory/CRDA
comment "crda needs a toolchain w/ threads, dynamic library"
- depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_PREFER_STATIC_LIB
+ depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405
diff --git a/package/crda/crda.mk b/package/crda/crda.mk
index f3d3e8009..3c06e075d 100644
--- a/package/crda/crda.mk
+++ b/package/crda/crda.mk
@@ -18,7 +18,7 @@ CRDA_LICENSE_FILES = LICENSE
#
# libgcrypt needs -lgpg-error if linking statically, which is correctly
# set by the libgcrypt-config script (and in the right order).
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ifeq ($(BR2_STATIC_LIBS),y)
CRDA_NLLIBS += -lnl-3 -lm -lpthread
CRDA_LDLIBS += `$(STAGING_DIR)/usr/bin/libgcrypt-config --libs`
endif