summaryrefslogtreecommitdiff
path: root/package/dbus/dbus.mk
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2013-10-06 01:39:55 +0200
committerPeter Korsgaard <peter@korsgaard.com>2013-10-06 12:55:29 +0200
commit561fb5f702cd84c6953803d44d1ce1204e85412f (patch)
tree8dcdb3eabdcbbfb5807f07e4c0d9369be3942edd /package/dbus/dbus.mk
parent6f6b103f6538de3e13d7c3098a498562e629a31f (diff)
dbus: fix static linking issue with pthread
-lpthread is missing when dbus is build with static lib Fixes build failures: http://autobuild.buildroot.net/results/80a317e33afd1d5ba2f7dd9ecd89314b09b4b1fe/ http://autobuild.buildroot.net/results/2c3c040624652547bbeec363d7d6b03f2477ff00/ Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dbus/dbus.mk')
-rw-r--r--package/dbus/dbus.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index d50f6309c..e2412478b 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -30,6 +30,10 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-system-pid-file=/var/run/messagebus.pid
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+DBUS_CONF_OPT += LIBS='-lpthread'
+endif
+
ifeq ($(BR2_microblaze),y)
# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
DBUS_CONF_OPT += --disable-inotify