summaryrefslogtreecommitdiff
path: root/package/dbus/dbus.mk
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/dbus/dbus.mk
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dbus/dbus.mk')
-rw-r--r--package/dbus/dbus.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 3f29a30a3..629673867 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -17,7 +17,7 @@ endef
DBUS_DEPENDENCIES = host-pkgconf expat
DBUS_CONF_ENV = ac_cv_have_abstract_sockets=yes
-DBUS_CONF_OPT = --with-dbus-user=dbus \
+DBUS_CONF_OPTS = --with-dbus-user=dbus \
--disable-tests \
--disable-asserts \
--enable-abstract-sockets \
@@ -35,28 +35,28 @@ define DBUS_USERS
endef
ifeq ($(BR2_PREFER_STATIC_LIB),y)
-DBUS_CONF_OPT += LIBS='-pthread'
+DBUS_CONF_OPTS += LIBS='-pthread'
endif
ifeq ($(BR2_microblaze),y)
# microblaze toolchain doesn't provide inotify_rm_* but does have sys/inotify.h
-DBUS_CONF_OPT += --disable-inotify
+DBUS_CONF_OPTS += --disable-inotify
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
-DBUS_CONF_OPT += --with-x
+DBUS_CONF_OPTS += --with-x
DBUS_DEPENDENCIES += xlib_libX11
else
-DBUS_CONF_OPT += --without-x
+DBUS_CONF_OPTS += --without-x
endif
ifeq ($(BR2_INIT_SYSTEMD),y)
-DBUS_CONF_OPT += \
+DBUS_CONF_OPTS += \
--enable-systemd \
--with-systemdsystemunitdir=/lib/systemd/system
DBUS_DEPENDENCIES += systemd
else
-DBUS_CONF_OPT += --disable-systemd
+DBUS_CONF_OPTS += --disable-systemd
endif
# fix rebuild (dbus makefile errors out if /var/lib/dbus is a symlink)
@@ -86,7 +86,7 @@ define DBUS_INSTALL_INIT_SYSV
endef
HOST_DBUS_DEPENDENCIES = host-pkgconf host-expat
-HOST_DBUS_CONF_OPT = \
+HOST_DBUS_CONF_OPTS = \
--with-dbus-user=dbus \
--disable-tests \
--disable-asserts \