summaryrefslogtreecommitdiff
path: root/package/dbus/dbus.mk
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2014-06-16 18:11:10 +0300
committerPeter Korsgaard <peter@korsgaard.com>2014-06-18 14:06:18 +0200
commitfd37dcc6048efab1a8a00d69b18f08871ecabda4 (patch)
tree1119aadcb2a7f2a80653f9617b647f80697a8eb9 /package/dbus/dbus.mk
parent8a92adb4e0a9351737ff9035bb264b310415870e (diff)
dbus: bump to version 1.8.4
Upstream removed support for libxml2 as xml backend, select expat unconditionally. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dbus/dbus.mk')
-rw-r--r--package/dbus/dbus.mk13
1 files changed, 3 insertions, 10 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 4bcc9538a..f8824eee5 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -4,7 +4,7 @@
#
################################################################################
-DBUS_VERSION = 1.6.18
+DBUS_VERSION = 1.8.4
DBUS_SITE = http://dbus.freedesktop.org/releases/dbus
DBUS_LICENSE = AFLv2.1 GPLv2+
DBUS_LICENSE_FILES = COPYING
@@ -14,7 +14,7 @@ define DBUS_PERMISSIONS
/usr/libexec/dbus-daemon-launch-helper f 4755 0 0 - - - - -
endef
-DBUS_DEPENDENCIES = host-pkgconf
+DBUS_DEPENDENCIES = host-pkgconf expat
DBUS_CONF_ENV = ac_cv_have_abstract_sockets=yes
DBUS_CONF_OPT = --with-dbus-user=dbus \
@@ -27,6 +27,7 @@ DBUS_CONF_OPT = --with-dbus-user=dbus \
--disable-static \
--disable-dnotify \
--localstatedir=/var \
+ --with-xml=expat \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-system-pid-file=/var/run/messagebus.pid
@@ -43,14 +44,6 @@ ifeq ($(BR2_microblaze),y)
DBUS_CONF_OPT += --disable-inotify
endif
-ifeq ($(BR2_DBUS_EXPAT),y)
-DBUS_CONF_OPT += --with-xml=expat
-DBUS_DEPENDENCIES += expat
-else
-DBUS_CONF_OPT += --with-xml=libxml
-DBUS_DEPENDENCIES += libxml2
-endif
-
ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
DBUS_CONF_OPT += --with-x
DBUS_DEPENDENCIES += xlib_libX11