summaryrefslogtreecommitdiff
path: root/package/dbus
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2014-07-03 18:57:34 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-15 23:27:16 +0200
commit95c914fae8ff20dac278aea9ae0d74595bf03b88 (patch)
treea056114f739e79ec0ce04807278ba7ed6abda372 /package/dbus
parent64b38f03a705fdbb40f0cf0186bbe38d611d1e10 (diff)
dbus: enable systemd support
Enable systemd support if systemd is selected as init system (require systemd compatibility libraries). Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/Config.in1
-rw-r--r--package/dbus/dbus.mk9
2 files changed, 8 insertions, 2 deletions
diff --git a/package/dbus/Config.in b/package/dbus/Config.in
index 653f7482f..7d49ce504 100644
--- a/package/dbus/Config.in
+++ b/package/dbus/Config.in
@@ -4,6 +4,7 @@ config BR2_PACKAGE_DBUS
# uses fork()
depends on BR2_USE_MMU
select BR2_PACKAGE_EXPAT
+ select BR2_PACKAGE_SYSTEMD_COMPAT if BR2_INIT_SYSTEMD
help
The D-Bus message bus system.
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 429c9230c..63cec6e46 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -50,8 +50,13 @@ else
DBUS_CONF_OPT += --without-x
endif
-ifeq ($(BR2_PACKAGE_SYSTEMD),y)
-DBUS_CONF_OPT += --with-systemdsystemunitdir=/lib/systemd/system
+ifeq ($(BR2_INIT_SYSTEMD),y)
+DBUS_CONF_OPT += \
+ --enable-systemd \
+ --with-systemdsystemunitdir=/lib/systemd/system
+DBUS_DEPENDENCIES += systemd
+else
+DBUS_CONF_OPT += --disable-systemd
endif
# fix rebuild (dbus makefile errors out if /var/lib/dbus is a symlink)