summaryrefslogtreecommitdiff
path: root/package/dhcp
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2013-07-19 14:46:37 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-19 23:39:43 +0200
commit4db37c663cc0988cf5993d14ee5fdb7976f45694 (patch)
tree94027053e4d63a0f1223fcb9ac4e50f93bde9e5c /package/dhcp
parentfb354d5faaa9b912e3d868b92622c11323d6ae9f (diff)
dhcp: add config option for delayed-ack feature of dhcp server
This patch creates a config option for the ISC DHCP server to allow passing --enable-delayed-ack to its configure script. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/dhcp')
-rw-r--r--package/dhcp/Config.in5
-rw-r--r--package/dhcp/dhcp.mk4
2 files changed, 9 insertions, 0 deletions
diff --git a/package/dhcp/Config.in b/package/dhcp/Config.in
index 38cf00796..e341485b1 100644
--- a/package/dhcp/Config.in
+++ b/package/dhcp/Config.in
@@ -13,6 +13,11 @@ config BR2_PACKAGE_DHCP_SERVER
help
DHCP server from the ISC DHCP distribution.
+config BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK
+ bool "Enable delayed ACK feature"
+ depends on BR2_PACKAGE_DHCP_SERVER
+ help
+ Enable delayed ACK feature in the ISC DHCP server.
config BR2_PACKAGE_DHCP_RELAY
bool "dhcp relay"
diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index ce0cf231d..3baeb2384 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -17,6 +17,10 @@ DHCP_CONF_OPT = \
--with-cli-pid-file=/var/run/dhclient.pid \
--with-relay-pid-file=/var/run/dhcrelay.pid
+ifeq ($(BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK),y)
+ DHCP_CONF_OPT += --enable-delayed-ack
+endif
+
ifneq ($(BR2_INET_IPV6),y)
DHCP_CONF_OPT += --disable-dhcpv6
endif