summaryrefslogtreecommitdiff
path: root/package/dhcp
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-11-11 10:08:56 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-11 15:33:48 +0100
commit654678ee746db67e3f7bd1ce80438db5c6883b85 (patch)
tree931d84d86b0ea6332eaba8b59c0e0fd3a9112535 /package/dhcp
parent143fe5b443da448c2652527cce299dab0c4fab96 (diff)
dhcp: fix bad --enable/disable-debug logic
It interprets disable as enable and wreaks havoc since it changes the behaviour of the build, for instance not using configured leases files paths. Thanks to Nathaniel Roach for pointing me to this problem. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Reviewed-by: Nathaniel Roach <nroach44@gmail.com> Tested-by: Nathaniel Roach <nroach44@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dhcp')
-rw-r--r--package/dhcp/0001-fix-configure-debug.patch23
-rw-r--r--package/dhcp/dhcp.mk2
2 files changed, 25 insertions, 0 deletions
diff --git a/package/dhcp/0001-fix-configure-debug.patch b/package/dhcp/0001-fix-configure-debug.patch
new file mode 100644
index 000000000..19c9bfe56
--- /dev/null
+++ b/package/dhcp/0001-fix-configure-debug.patch
@@ -0,0 +1,23 @@
+AC_ARG_ENABLE is passed wrong parameters for action-if-given:
+If someone passed --enable-debug to configure enable_debug was set to 'yes',
+but if --disable-debug was passed the action is also called and debug was
+also set to 'yes' which is wrong.
+Use $enableval for this case.
+
+Reported upstream as ISC-Bugs #37780 (not publicly accesible).
+Thanks to Nathaniel Roach for pointing out the problem.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura dhcp-4.1-ESV-R10.orig/configure.ac dhcp-4.1-ESV-R10/configure.ac
+--- dhcp-4.1-ESV-R10.orig/configure.ac 2014-11-11 09:50:07.719277076 -0300
++++ dhcp-4.1-ESV-R10/configure.ac 2014-11-11 09:51:10.722432148 -0300
+@@ -53,7 +53,7 @@
+ AC_ARG_ENABLE(debug,
+ AC_HELP_STRING([--enable-debug],
+ [create a debug-only version of the software (default is no).]),
+- [enable_debug=yes],[enable_debug=no])
++ [enable_debug=$enableval],[enable_debug=no])
+ # This is very much off by default.
+ if test "$enable_debug" = "yes" ; then
+ AC_DEFINE([DEBUG], [1],
diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index 8b38fd0a2..27fb60b74 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -9,6 +9,8 @@ DHCP_SITE = http://ftp.isc.org/isc/dhcp/$(DHCP_VERSION)
DHCP_INSTALL_STAGING = YES
DHCP_LICENSE = ISC
DHCP_LICENSE_FILES = LICENSE
+# For 0001-fix-configure-debug.patch
+DHCP_AUTORECONF = YES
DHCP_CONF_ENV = \
CPPFLAGS='-D_PATH_DHCPD_CONF=\"/etc/dhcp/dhcpd.conf\" \
-D_PATH_DHCLIENT_CONF=\"/etc/dhcp/dhclient.conf\"' \