summaryrefslogtreecommitdiff
path: root/package/dhrystone
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-09-13 23:13:20 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-09-13 23:13:20 +0200
commit38c291cd955c8bc3d66f332de6bbdc23c94dded2 (patch)
treeac8032fe0a9b2f46890b7a07e42f608c4af8726c /package/dhrystone
parent1cb27b6049c4ebf0a82ace4606a93bbd46612834 (diff)
dhrystone: pass HZ=100 to fix build issue on musl
Fixes: http://autobuild.buildroot.net/results/1b6cb1b40431bf484db2d99bfdc8237cbae6a9d7/ http://autobuild.buildroot.net/results/20e669d6e4bc3d872a355ef658ddad8f34676624/ musl doesn't provide sys/param.h to figure out the value of HZ, but as we know we are building for Linux, and on Linux the clock_t values returned from times(2) are defined in terms of USER_HZ which is always 100, we can just as well tell dhrystone to use that directly. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dhrystone')
-rw-r--r--package/dhrystone/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/dhrystone/Makefile b/package/dhrystone/Makefile
index d628ddb50..f7a212b2f 100644
--- a/package/dhrystone/Makefile
+++ b/package/dhrystone/Makefile
@@ -1,4 +1,4 @@
-CPPFLAGS += -DNO_PROTOTYPES=1
+CPPFLAGS += -DNO_PROTOTYPES=1 -DHZ=100
LDLIBS += -lm
all: dhrystone