summaryrefslogtreecommitdiff
path: root/package/doc-asciidoc.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-07-17 12:34:23 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-27 21:57:12 +0200
commit3c695928f593d2f7eff3d8ac60fcd9ac21a26c57 (patch)
treea11fd301c06016f62921008f77f273c0fcd7a2fb /package/doc-asciidoc.mk
parent4802db3dad05ff8926d4fb462fc9282c07544487 (diff)
doc/asciidoc: add possibility to define document dependencies
Currently, a document can not have dependencies, except for the purely internal ones (like checking asciidoc version, and presence of dblatex). For our own manual, this will come in handy when we introduce a generated kconfig snippet, so we can actually make the manual depend on that snippet being generated first. For external documents, it can be used to depend on host-packages if need be (e.g. a custom host packages that generates specific media files included in the manual). Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Samuel Martin <s.martin49@gmail.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/doc-asciidoc.mk')
-rw-r--r--package/doc-asciidoc.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/doc-asciidoc.mk b/package/doc-asciidoc.mk
index 4f765b885..cb6e61660 100644
--- a/package/doc-asciidoc.mk
+++ b/package/doc-asciidoc.mk
@@ -141,7 +141,7 @@ endef
################################################################################
define ASCIIDOC
# Single line, because splitting a foreach is not easy...
-$(1)-check-dependencies: asciidoc-check-dependencies
+$(1)-check-dependencies: asciidoc-check-dependencies $$($(2)_DEPENDENCIES)
$$(Q)$$(foreach hook,$$($(2)_CHECK_DEPENDENCIES_HOOKS),$$(call $$(hook))$$(sep))
# Single line, because splitting a foreach is not easy...