summaryrefslogtreecommitdiff
path: root/package/dovecot
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-10 21:58:18 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-16 23:06:55 +0100
commitb9ddfddf9d7f22c61f0857d4bde731f94bace8d8 (patch)
tree26b7213bde2b02567ba9fc2bfe3ef8f6c5dd7f83 /package/dovecot
parentf39ac4d288858989782c8321f9da78236a11a3c9 (diff)
package/dovecot: add optional support for xz
When xz was compiled before, dovecot will use it as optional dependency: $ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/lib/dovecot/lib30_imap_zlib_plugin.so | grep NEEDED 0x00000001 (NEEDED) Shared library: [libz.so.1] 0x00000001 (NEEDED) Shared library: [liblzma.so.5] 0x00000001 (NEEDED) Shared library: [liblz4.so.1] 0x00000001 (NEEDED) Shared library: [libc.so.1] (lz4 support will be added with the next patch of this series) Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/dovecot')
-rw-r--r--package/dovecot/dovecot.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/dovecot/dovecot.mk b/package/dovecot/dovecot.mk
index eea9efcc2..dbf2dab10 100644
--- a/package/dovecot/dovecot.mk
+++ b/package/dovecot/dovecot.mk
@@ -76,6 +76,13 @@ else
DOVECOT_CONF_OPTS += --without-sqlite
endif
+ifeq ($(BR2_PACKAGE_XZ),y)
+DOVECOT_CONF_OPTS += --with-lzma
+DOVECOT_DEPENDENCIES += xz
+else
+DOVECOT_CONF_OPTS += --without-lzma
+endif
+
ifeq ($(BR2_PACKAGE_ZLIB),y)
DOVECOT_CONF_OPTS += --with-zlib
DOVECOT_DEPENDENCIES += zlib