summaryrefslogtreecommitdiff
path: root/package/dropbear
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-08-18 21:25:53 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-08-24 17:06:06 +0200
commit29a0f0557984ccb299426712b71fee5abaaa2ca9 (patch)
treef5e6670ec6113835fc8105b447bfc5b46c024133 /package/dropbear
parent7deaa277fd4c89c67de39ea21b4cd081ab85366f (diff)
package/dropbear: fix when readlink is from busybox
Busybox "readlink -f" does not canonicalise paths when the target is missing, while coreutils do. Fix that by: - making an absolute symlink - dropping "-f" when calling readlink Fixes #8276. Reported-by: Jason Tang <tang@jtang.org> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Paul Cercueil <paul@crapouillou.net> Cc: Alexandre Belloni <alexandre.belloni@free-electrons.com> Tested-by: Jason Tang <tang@jtang.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dropbear')
-rw-r--r--package/dropbear/S50dropbear2
-rw-r--r--package/dropbear/dropbear.mk2
-rw-r--r--package/dropbear/dropbear.service2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/dropbear/S50dropbear b/package/dropbear/S50dropbear
index 893878950..765d6a3e1 100644
--- a/package/dropbear/S50dropbear
+++ b/package/dropbear/S50dropbear
@@ -18,7 +18,7 @@ start() {
# - the filesystem is RW (i.e. we can rm the symlink),
# replace the symlink with an actual directory
if [ -L /etc/dropbear \
- -a "$(readlink -f /etc/dropbear)" = "/var/run/dropbear" ]
+ -a "$(readlink /etc/dropbear)" = "/var/run/dropbear" ]
then
if rm -f /etc/dropbear; then
mkdir -p /etc/dropbear
diff --git a/package/dropbear/dropbear.mk b/package/dropbear/dropbear.mk
index 5bbe86450..aa3fd9d92 100644
--- a/package/dropbear/dropbear.mk
+++ b/package/dropbear/dropbear.mk
@@ -93,7 +93,7 @@ define DROPBEAR_INSTALL_TARGET_CMDS
for f in $(DROPBEAR_TARGET_BINS); do \
ln -snf ../sbin/dropbear $(TARGET_DIR)/usr/bin/$$f ; \
done
- ln -snf ../var/run/dropbear $(TARGET_DIR)/etc/dropbear
+ ln -snf /var/run/dropbear $(TARGET_DIR)/etc/dropbear
endef
$(eval $(autotools-package))
diff --git a/package/dropbear/dropbear.service b/package/dropbear/dropbear.service
index 52c77024f..9dcbf256c 100644
--- a/package/dropbear/dropbear.service
+++ b/package/dropbear/dropbear.service
@@ -10,7 +10,7 @@ After=syslog.target network.target auditd.service
# replace the symlink with an actual directory
ExecStartPre=/bin/sh -c '\
if [ -L /etc/dropbear \
- -a "$(readlink -f /etc/dropbear)" = "/var/run/dropbear" ]; then \
+ -a "$(readlink /etc/dropbear)" = "/var/run/dropbear" ]; then \
if rm -f /etc/dropbear; then \
mkdir -p /etc/dropbear; \
else \