summaryrefslogtreecommitdiff
path: root/package/dvdauthor
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-06-19 18:20:28 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-06-19 23:08:18 +0200
commitbf5c4641823e3e4c4669348a547b540a276ece67 (patch)
tree04d569adc8fa47ebc433219437ea62a9700dfead /package/dvdauthor
parent0306b5926493e3b153ed32f20f131f0407552bdb (diff)
package/dvdauthor: libdvdread can now be linked statically
After libdvdread bump to version 5.0.3 static linking works, tested using this defconfig: http://autobuild.buildroot.net/toolchains/configs/br-arm-full-static.config Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/dvdauthor')
-rw-r--r--package/dvdauthor/Config.in5
-rw-r--r--package/dvdauthor/dvdauthor.mk4
2 files changed, 4 insertions, 5 deletions
diff --git a/package/dvdauthor/Config.in b/package/dvdauthor/Config.in
index 6f8e2e438..8b2bcb3d6 100644
--- a/package/dvdauthor/Config.in
+++ b/package/dvdauthor/Config.in
@@ -17,13 +17,8 @@ if BR2_PACKAGE_DVDAUTHOR
config BR2_PACKAGE_DVDAUTHOR_DVDUNAUTHOR
bool "dvdunauthor"
select BR2_PACKAGE_LIBDVDREAD
- depends on !BR2_STATIC_LIBS # libdvdread
help
This option enables the dvdunauthor program, which requires
libdvdread.
-comment "dvdunauthor needs a toolchain w/ dynamic library"
- depends on BR2_STATIC_LIBS
-
endif
-
diff --git a/package/dvdauthor/dvdauthor.mk b/package/dvdauthor/dvdauthor.mk
index 6b90c43c3..e982a40e4 100644
--- a/package/dvdauthor/dvdauthor.mk
+++ b/package/dvdauthor/dvdauthor.mk
@@ -40,6 +40,10 @@ endif
ifeq ($(BR2_PACKAGE_DVDAUTHOR_DVDUNAUTHOR),y)
DVDAUTHOR_DEPENDENCIES += libdvdread
+# dvdauthor configure does not use pkg-config to detect libdvdread
+ifeq ($(BR2_PACKAGE_LIBDVDCSS)$(BR2_STATIC_LIBS),yy)
+DVDAUTHOR_CONF_ENV += LIBS="-ldvdcss"
+endif
DVDAUTHOR_CONF_OPTS += --enable-dvdunauthor
else
DVDAUTHOR_CONF_OPTS += --disable-dvdunauthor