summaryrefslogtreecommitdiff
path: root/package/e2tools
diff options
context:
space:
mode:
authorDaniel Nyström <daniel.nystrom@timeterminal.se>2009-07-06 22:28:52 +0800
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-20 23:43:51 +0200
commit42ec5e049af5c77f18e1facd52927b2f74ee3b9e (patch)
tree382aa31993ed59f09d86e43765f510bc5ca2dca2 /package/e2tools
parentdc4d0e2f5cc783a826b3bfe4d31c00840407a8e2 (diff)
e2tools: new package
E2tools is a simple set of GPL'ed utilities to read, write, and manipulate files in an ext2/ext3 filesystem. These utilities access a filesystem directly using the ext2fs library. [Thomas: add toolchain dependencies as needed, use full Git hash, use github helper, add support for host version.] Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/e2tools')
-rw-r--r--package/e2tools/Config.in17
-rw-r--r--package/e2tools/Config.in.host10
-rw-r--r--package/e2tools/e2tools.mk19
3 files changed, 46 insertions, 0 deletions
diff --git a/package/e2tools/Config.in b/package/e2tools/Config.in
new file mode 100644
index 000000000..13e211861
--- /dev/null
+++ b/package/e2tools/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_E2TOOLS
+ bool "e2tools"
+ select BR2_PACKAGE_E2FSPROGS
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_LARGEFILE # e2fsprogs
+ depends on BR2_USE_WCHAR # e2fsprogs
+ depends on BR2_USE_MMU # e2fsprogs
+ help
+ E2tools is a simple set of GPL'ed utilities to read, write,
+ and manipulate files in an ext2/ext3 filesystem. These
+ utilities access a filesystem directly using the ext2fs
+ library.
+
+ https://github.com/ndim/e2tools
+
+comment "e2tools needs a toolchain w/ threads, largefile and wchar"
+ depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/e2tools/Config.in.host b/package/e2tools/Config.in.host
new file mode 100644
index 000000000..772262a0f
--- /dev/null
+++ b/package/e2tools/Config.in.host
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_HOST_E2TOOLS
+ bool "host-e2tools"
+ select BR2_PACKAGE_HOST_E2FSPROGS
+ help
+ E2tools is a simple set of GPL'ed utilities to read, write,
+ and manipulate files in an ext2/ext3 filesystem. These
+ utilities access a filesystem directly using the ext2fs
+ library.
+
+ https://github.com/ndim/e2tools
diff --git a/package/e2tools/e2tools.mk b/package/e2tools/e2tools.mk
new file mode 100644
index 000000000..97afcc074
--- /dev/null
+++ b/package/e2tools/e2tools.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# e2tools
+#
+################################################################################
+
+E2TOOLS_VERSION = 3158ef18a903ca4a98b8fa220c9fc5c133d8bdf6
+E2TOOLS_SITE = $(call github,ndim,e2tools,$(E2TOOLS_VERSION))
+
+# Source coming from github, no configure included.
+E2TOOLS_AUTORECONF = YES
+E2TOOLS_LICENSE = GPLv2
+E2TOOLS_LICENSE_FILES = COPYING
+E2TOOLS_DEPENDENCIES = e2fsprogs
+E2TOOLS_CONF_ENV = LIBS="-lpthread"
+HOST_E2TOOLS_CONF_ENV = LIBS="-lpthread"
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))