summaryrefslogtreecommitdiff
path: root/package/efl
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-09-07 23:08:41 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-17 18:26:35 +0200
commit373c24cd1bb98a8b826b92034f7cb39780719625 (patch)
treea36b3bcdbc937af63c6c4ea9b179d9b47e18c2fa /package/efl
parent87b73f50a3df962e2b07a966557f888dec89c2cc (diff)
package/efl: enable elput support
Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: - add --disable-elput in the !BR2_PACKAGE_EFL_ELPUT case - add missing dependency on libxkbcomm] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/Config.in10
-rw-r--r--package/efl/efl.mk7
2 files changed, 17 insertions, 0 deletions
diff --git a/package/efl/Config.in b/package/efl/Config.in
index fa6d7617e..f963ade8e 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -183,6 +183,16 @@ config BR2_PACKAGE_EFL_OPENGL_NONE
endchoice # OpenGL support
+config BR2_PACKAGE_EFL_ELPUT
+ bool "Elput"
+ select BR2_PACKAGE_LIBINPUT
+ select BR2_PACKAGE_LIBXKBCOMMON
+ help
+ The elput library is an efl abstraction for the libinput library
+ which can be used by various other subsystems (ecore_fb,
+ ecore_drm, etc) to handle interfacing with libinput without
+ having to duplicate the code in each subsystem.
+
comment "libevas loaders"
config BR2_PACKAGE_EFL_PNG
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 853c9dcb5..80387393f 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -152,6 +152,13 @@ else
EFL_CONF_OPTS += --disable-wayland
endif
+ifeq ($(BR2_PACKAGE_EFL_ELPUT),y)
+EFL_CONF_OPTS += --enable-elput
+EFL_DEPENDENCIES += libinput libxkbcommon
+else
+EFL_CONF_OPTS += --disable-elput
+endif
+
ifeq ($(BR2_PACKAGE_EFL_FB),y)
EFL_CONF_OPTS += --enable-fb
else