summaryrefslogtreecommitdiff
path: root/package/efl
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@profusion.mobi>2016-12-30 12:51:04 -0200
committerPeter Korsgaard <peter@korsgaard.com>2017-01-08 21:55:09 +0100
commitc78f24301c5d226473799306f587e59265580907 (patch)
tree2889190284bb329d15ce64077c8c68032cd98e3a /package/efl
parentfa4a05fe639cd9f68df79bb4a3d9c2673a337c6a (diff)
efl: optional 'upower' ecore system module.
Ecore will reach 'upower' using D-Bus system bus in order to detect if the system state changes and let applications know about the power state such as low battery or AC power in order to optimize their power consumption. For host this is not needed and would not work, since output/host DBus declares its own output/host/var/run/dbus/system_bus_socket, which has no dbus-daemon and thus no services in it. For target it's optional and only installed if BR2_PACKAGE_UPOWER=y, otherwise it prints error messages about missing upower service. Signed-off-by: Gustavo Sverzut Barbieri <barbieri@profusion.mobi> Reviewed-by: Romain Naour <romain.naour@gmail.com> Acked-by: Romain Naour <romain.naour@gmail.com> Tested-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/efl.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 7a8e47f4c..2fe140a30 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -272,6 +272,18 @@ else
EFL_CONF_OPTS += --disable-librsvg
endif
+ifeq ($(BR2_PACKAGE_UPOWER),)
+# upower ecore system module is only useful if upower
+# dbus service is available.
+# It's not essential, only used to notify applications
+# of power state, such as low battery or AC power, so
+# they can adapt their power consumption.
+define EFL_HOOK_REMOVE_UPOWER
+ rm -fr $(TARGET_DIR)/usr/lib/ecore/system/upower
+endef
+EFL_POST_INSTALL_TARGET_HOOKS = EFL_HOOK_REMOVE_UPOWER
+endif
+
$(eval $(autotools-package))
################################################################################
@@ -352,4 +364,13 @@ else
HOST_EFL_CONF_OPTS += --disable-cxx-bindings
endif
+# Always disable upower system module from host as it's
+# not useful and would try to use the output/host/var
+# system bus which is non-existent and does not contain
+# any upower service in it.
+define HOST_EFL_HOOK_REMOVE_UPOWER
+ rm -fr $(HOST_DIR)/usr/lib/ecore/system/upower
+endef
+HOST_EFL_POST_INSTALL_HOOKS = HOST_EFL_HOOK_REMOVE_UPOWER
+
$(eval $(host-autotools-package))