summaryrefslogtreecommitdiff
path: root/package/erlang-p1-zlib
diff options
context:
space:
mode:
authorJohan Oudinet <johan.oudinet@gmail.com>2015-01-12 10:32:10 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-03 10:23:11 +0100
commit80137e0e7d173106a6bebac63447a7625692bcd5 (patch)
tree73c7e6c9dc320e14678261a0b8e899276959f9fe /package/erlang-p1-zlib
parent1a32f6bf2b3b7e3a426538226e4d19098328a7df (diff)
erlang-p1-zlib: new package.
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/erlang-p1-zlib')
-rw-r--r--package/erlang-p1-zlib/Config.in7
-rw-r--r--package/erlang-p1-zlib/erlang-p1-zlib.mk13
2 files changed, 20 insertions, 0 deletions
diff --git a/package/erlang-p1-zlib/Config.in b/package/erlang-p1-zlib/Config.in
new file mode 100644
index 000000000..b7e48a149
--- /dev/null
+++ b/package/erlang-p1-zlib/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_ERLANG_P1_ZLIB
+ bool "erlang-p1-zlib"
+ select BR2_PACKAGE_ZLIB
+ help
+ Erlang interface to zlib
+
+ https://github.com/processone/zlib
diff --git a/package/erlang-p1-zlib/erlang-p1-zlib.mk b/package/erlang-p1-zlib/erlang-p1-zlib.mk
new file mode 100644
index 000000000..4ba3332e3
--- /dev/null
+++ b/package/erlang-p1-zlib/erlang-p1-zlib.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# erlang-p1-zlib
+#
+################################################################################
+
+ERLANG_P1_ZLIB_VERSION = 52e82bb
+ERLANG_P1_ZLIB_SITE = $(call github,processone,zlib,$(ERLANG_P1_ZLIB_VERSION))
+ERLANG_P1_ZLIB_LICENSE = GPLv2+
+ERLANG_P1_ZLIB_LICENSE_FILES = COPYING
+ERLANG_P1_ZLIB_DEPENDENCIES = zlib
+
+$(eval $(rebar-package))