summaryrefslogtreecommitdiff
path: root/package/expedite
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-12-12 14:33:04 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-12 14:37:04 +0100
commit15d288520c10b7edf311e87b3ae45503957a66f6 (patch)
tree595e0b5951680770ae767023af69d49d589ef1ac /package/expedite
parent525dfab33cb4113e3e0833460a48fff20e669781 (diff)
package/expedite: move to package directory
There is no advantage for efl related packages to share the same version number anymore (except for Efl and Elementary). Here are the version number used for the 1.15 stable release: EFL 1.15.2 Elementary 1.15.2 Emotion Generic Players 1.15.0 Evas Generic Loaders 1.15.0 Python-EFL 1.15.0 Also, we usually do not have a sub-directory for a family of related packages which don't share the same version number, so move expedite to the package directory. Expedite now appears in the "Graphic libraries and applications (graphic/text)" in the Kconfig menu. In a followup patch, expedite will be downloaded directly from the 1.15 branch in the git repository since there is no new tarball release after 1.7.0. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/expedite')
-rw-r--r--package/expedite/Config.in16
-rw-r--r--package/expedite/expedite.mk20
2 files changed, 36 insertions, 0 deletions
diff --git a/package/expedite/Config.in b/package/expedite/Config.in
new file mode 100644
index 000000000..de6a056b0
--- /dev/null
+++ b/package/expedite/Config.in
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_EXPEDITE
+ bool "expedite"
+ select BR2_PACKAGE_LIBEINA
+ select BR2_PACKAGE_LIBEVAS
+ select BR2_PACKAGE_LIBEET
+ depends on BR2_PACKAGE_EFL
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libevas
+ help
+ Expedite is the official Evas benchmark tool. It can test different
+ engines, such as X11, XRender, OpenGL (also ES variant), SDL,
+ DirectFB and so on. Its tests are quite extensive, trying to
+ reproduce real world usage cases.
+
+comment "expedite needs a toolchain w/ C++, threads"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/expedite/expedite.mk b/package/expedite/expedite.mk
new file mode 100644
index 000000000..9b232f834
--- /dev/null
+++ b/package/expedite/expedite.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# expedite
+#
+################################################################################
+
+EXPEDITE_VERSION = 1.7.10
+EXPEDITE_SITE = http://download.enlightenment.org/releases
+EXPEDITE_LICENSE = BSD-2c
+EXPEDITE_LICENSE_FILES = COPYING
+
+EXPEDITE_DEPENDENCIES = libevas libeina libeet
+
+ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
+EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
+ --x-includes=$(STAGING_DIR)/usr/include \
+ --x-libraries=$(STAGING_DIR)/usr/lib
+endif
+
+$(eval $(autotools-package))