summaryrefslogtreecommitdiff
path: root/package/fakeroot
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-11-27 20:31:50 +0100
committerPeter Korsgaard <peter@korsgaard.com>2016-11-27 21:12:24 +0100
commit907ea41c5298e6d086c49fb7507e1db036d3c4d2 (patch)
tree9223b6aa4f99e1a04cd19463411c3fe92f84a695 /package/fakeroot
parent4c6d5e33ae1bdfc85c9734897c357a804bfd7435 (diff)
Revert "package/fakeroot: remove"
This reverts commit 325cff36f74b07545389b81cee0a2acef55b487c. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/fakeroot')
-rw-r--r--package/fakeroot/0001-hide-dlsym-error.patch34
-rw-r--r--package/fakeroot/fakeroot.hash4
-rw-r--r--package/fakeroot/fakeroot.mk20
3 files changed, 58 insertions, 0 deletions
diff --git a/package/fakeroot/0001-hide-dlsym-error.patch b/package/fakeroot/0001-hide-dlsym-error.patch
new file mode 100644
index 000000000..2c61fab24
--- /dev/null
+++ b/package/fakeroot/0001-hide-dlsym-error.patch
@@ -0,0 +1,34 @@
+Description: Hide error from dlsym()
+ dlsym(), starting in glibc 2.24 actually reports errors. In our case,
+ we try to get ACL functions which are not in the glibc. This causes
+ failures in test suites, so hide those messages for non-debugging
+ purposes for now. It also makes the build logs annoying to read.
+Author: Julian Andres Klode <juliank@ubuntu.com>
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/830912
+Forwarded: no
+Last-Update: 2016-08-12
+
+Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
+
+--- a/libfakeroot.c
++++ b/libfakeroot.c
+@@ -256,10 +256,16 @@ void load_library_symbols(void){
+ /* clear dlerror() just in case dlsym() legitimately returns NULL */
+ msg = dlerror();
+ *(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
++
+ if ( (msg = dlerror()) != NULL){
+- fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
+-/* abort ();*/
++#ifdef LIBFAKEROOT_DEBUGGING
++ if (fakeroot_debug) {
++ fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
++/* abort ();*/
++ }
++#endif
+ }
++
+ }
+ }
+
diff --git a/package/fakeroot/fakeroot.hash b/package/fakeroot/fakeroot.hash
new file mode 100644
index 000000000..f0d436e5c
--- /dev/null
+++ b/package/fakeroot/fakeroot.hash
@@ -0,0 +1,4 @@
+# From http://snapshot.debian.org/package/fakeroot/1.20.2-1/
+sha1 367040df07043edb630942b21939e493f3fad888 fakeroot_1.20.2.orig.tar.bz2
+# Calculated based on the hash above
+sha256 7c0a164d19db3efa9e802e0fc7cdfeff70ec6d26cdbdc4338c9c2823c5ea230c fakeroot_1.20.2.orig.tar.bz2
diff --git a/package/fakeroot/fakeroot.mk b/package/fakeroot/fakeroot.mk
new file mode 100644
index 000000000..168cd13a4
--- /dev/null
+++ b/package/fakeroot/fakeroot.mk
@@ -0,0 +1,20 @@
+################################################################################
+#
+# fakeroot
+#
+################################################################################
+
+FAKEROOT_VERSION = 1.20.2
+FAKEROOT_SOURCE = fakeroot_$(FAKEROOT_VERSION).orig.tar.bz2
+FAKEROOT_SITE = http://snapshot.debian.org/archive/debian/20141005T221953Z/pool/main/f/fakeroot
+# Force capabilities detection off
+# For now these are process capabilities (faked) rather than file
+# so they're of no real use
+HOST_FAKEROOT_CONF_ENV = \
+ ac_cv_header_sys_capability_h=no \
+ ac_cv_func_capset=no
+
+FAKEROOT_LICENSE = GPLv3+
+FAKEROOT_LICENSE_FILES = COPYING
+
+$(eval $(host-autotools-package))