summaryrefslogtreecommitdiff
path: root/package/ffmpeg
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2015-10-15 13:22:55 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-17 16:33:03 +0200
commit8849e806d1c737a4b8404026efceabe9882f0b55 (patch)
tree5a85b3da74ce761108fdc772a39a2a0432c043fb /package/ffmpeg
parent3901cb515762aee9b6af67216419a9c5b83eec3d (diff)
ffmpeg: let the user override the --cpu value
Grab the content of BR2_PACKAGE_FFMPEG_EXTRACONF after guessing the CPU, so the user will still have the possibility to override it. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ffmpeg')
-rw-r--r--package/ffmpeg/ffmpeg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index f28eed863..287338d95 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -444,14 +444,14 @@ else
FFMPEG_CONF_OPTS += --disable-pic
endif
-FFMPEG_CONF_OPTS += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
-
ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_CPU)
else ifneq ($(call qstrip,$(BR2_GCC_TARGET_ARCH)),)
FFMPEG_CONF_OPTS += --cpu=$(BR2_GCC_TARGET_ARCH)
endif
+FFMPEG_CONF_OPTS += $(call qstrip,$(BR2_PACKAGE_FFMPEG_EXTRACONF))
+
# Override FFMPEG_CONFIGURE_CMDS: FFmpeg does not support --target and others
define FFMPEG_CONFIGURE_CMDS
(cd $(FFMPEG_SRCDIR) && rm -rf config.cache && \