summaryrefslogtreecommitdiff
path: root/package/ffmpeg
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-05-26 16:54:20 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-26 21:18:52 +0200
commitbd8cbe16c4e3909da13528d72b2573efc8d355fd (patch)
tree164fcbefa121ee2060e0c66520046a57173df3d7 /package/ffmpeg
parente6e549b9e40d42dbb6a551ecaeb040c1e401f21a (diff)
ffmpeg: disable for mips64r2 and mips64r6
MIPS architecture detection is not accurate and is always detected as mips64 even if we are using mips64r2 or mips64r6. Due to that, ffmpeg's build system will pass the -mips64 flag which will conflict with the -march option that our toolchain wrapper uses, and it will fail to build showing errors like this one: error: '-mips64' conflicts with the other architecture options, which specify a mips64r2 processor This problem has been already fixed upstream, but we would need to backport 17 patches plus some changes in the ffmpeg.mk file. This is too much, so better to just disable ffmpeg for mips64r2 and mips64r6 for the upcoming Buildroot release. This commit can be reverted in the next ffmpeg's version bump. Fixes: http://autobuild.buildroot.net/results/7fd/7fd8187c0110cdcac622e667f4a81d2db84f11ef/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ffmpeg')
-rw-r--r--package/ffmpeg/Config.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/ffmpeg/Config.in b/package/ffmpeg/Config.in
index 6b7a6e7b1..096ff95c2 100644
--- a/package/ffmpeg/Config.in
+++ b/package/ffmpeg/Config.in
@@ -1,7 +1,8 @@
config BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
bool
# fenv.h lacks FE_INVALID, FE_OVERFLOW & FE_UNDERFLOW on nios2
- default y if !BR2_nios2
+ # ffmpeg's configure script only supports mips64 (r1) variant
+ default y if !BR2_nios2 && !BR2_mips_64r2 && !BR2_mips_64r6
menuconfig BR2_PACKAGE_FFMPEG
bool "ffmpeg"