summaryrefslogtreecommitdiff
path: root/package/ffmpeg
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-10 23:29:04 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-08-17 00:01:38 +0200
commitfdd0f8d5e421d858d84bac186a5f3a3ae82a29c5 (patch)
treebadb6782771ed7a1d2967b4d42e3fb16f40dd5c4 /package/ffmpeg
parentae7becfe50cca2f6000342475f52750cab53985c (diff)
ffmpeg: don't pass --enable-mipsfpu on non-MIPS platform
The current logic to pass the --{enable,disable}-mipsfpu option is: ifeq ($(BR2_MIPS_SOFT_FLOAT),y) FFMPEG_CONF_OPTS += --disable-mipsfpu else FFMPEG_CONF_OPTS += --enable-mipsfpu endif In practice, this means that on MIPS soft-float, --disable-mipsfpu is passed, and that in *all* other cases, --enable-mipsfpu is passed, including if we are *not* targetting the MIPS architecture. Even though this doesn't seem to cause any problem, it is a bit weird to see --enable-mipsfpu when you're building ffmpeg for a non-MIPS architecture, so we better fix this by enclosing the MIPS-related options in a MIPS condition. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ffmpeg')
-rw-r--r--package/ffmpeg/ffmpeg.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/ffmpeg/ffmpeg.mk b/package/ffmpeg/ffmpeg.mk
index 2b4219a3a..5a1961799 100644
--- a/package/ffmpeg/ffmpeg.mk
+++ b/package/ffmpeg/ffmpeg.mk
@@ -441,6 +441,7 @@ else
FFMPEG_CONF_OPTS += --disable-neon
endif
+ifeq ($(BR2_mips)$(BR2_mipsel)$(BR2_mips64)$(BR2_mips64el),y)
ifeq ($(BR2_MIPS_SOFT_FLOAT),y)
FFMPEG_CONF_OPTS += --disable-mipsfpu
else
@@ -454,6 +455,7 @@ else
FFMPEG_CONF_OPTS += \
--disable-mips32r2
endif
+endif # MIPS
ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
FFMPEG_CONF_OPTS += --enable-altivec